Bug 459112 - rt28x0 ralink drivers not included in the distribution
rt28x0 ralink drivers not included in the distribution
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-14 10:34 EDT by Roderic Morris
Modified: 2008-08-14 14:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-14 14:45:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roderic Morris 2008-08-14 10:34:03 EDT
Description of problem:
Ralink has made available free, gpled drivers for their rt2860 and rt2870 wireless cards for at least 2 months, but they haven't been included in the kernel. Users are forced to configure and compile the package themselves, and reinstall each kernel update. The rt2860 is used in the eeepc 910 and 1000, so including these drivers would help users with those machines (including me).

Additional info:
I couldn't actually get the drivers to compile on rawhide because I couldn't boot into the kernel associated with my installed kernel-devel package. I was able to do so on debian testing however with the help of this http://ciaranm.wordpress.com/2008/07/14/edimax-ew-7728in-80211n-ralink-rt2860-with-linux-2626/ (it still applies, even though the version used there is old).
Comment 1 John W. Linville 2008-08-14 14:45:43 EDT
Ivo is working on upstream drivers for that hardware.  The vendor drivers will not be merged.

Note You need to log in before you can comment on or make changes to this bug.