Bug 459130 - Session exceptions aren't handled gracefully in java client
Session exceptions aren't handled gracefully in java client
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-java (Show other bugs)
1.0
All Linux
urgent Severity medium
: 1.0.1
: ---
Assigned To: Rafael H. Schloming
Kim van der Riet
:
Depends On:
Blocks: 460187
  Show dependency treegraph
 
Reported: 2008-08-14 12:05 EDT by Gordon Sim
Modified: 2014-12-01 18:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-06 15:08:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordon Sim 2008-08-14 12:05:00 EDT
If broker closes a session after an exceptional condition, the client throws a NullPointerException rather than somehow communicating the original condition.
Comment 2 Frantisek Reznicek 2008-09-16 10:49:53 EDT
RHTS test MRG_Messaging/qpid_java_exceptions_bz459130 shows that java client now currently reports the rootcause of exception. (->VERIFIED)


ADDITIONAL INFO:
[root@dhcp-lab-200 bin]# bash ./qpid-bench --mode publish
broker = localhost
port = 5672
count = 1000000
window = 100000
sample = 100000
size = 1024
mode = PUBLISH
timestamp = false
message_id = false
message_cache = false
persistent = false
jms_publish = false
jms_consume = false
help = false
NP: Tue Sep 16 10:20:52 CEST 2008
Exception in thread "Thread-2" java.lang.RuntimeException: org.apache.qpid.transport.SessionException: [ch=0 id=0 ExecutionException(errorCode=RESOURCE_LIMIT_EXCEEDED, commandId=8, classCode=0, commandCode=0, fieldIndex=0, description=resource-limit-exceeded: Policy exceeded for test-queue size: max=100, current=2048; count unlimited, current=0 (qpid/broker/Queue.cpp:418), errorInfo={})]
        at org.apache.qpid.tools.QpidBench$2.run(QpidBench.java:460)
Caused by: org.apache.qpid.transport.SessionException: [ch=0 id=0 ExecutionException(errorCode=RESOURCE_LIMIT_EXCEEDED, commandId=8, classCode=0, commandCode=0, fieldIndex=0, description=resource-limit-exceeded: Policy exceeded for test-queue size: max=100, current=2048; count unlimited, current=0 (qpid/broker/Queue.cpp:418), errorInfo={})]
        at org.apache.qpid.transport.Session.invoke(Session.java:276)
        at org.apache.qpid.transport.Invoker.messageTransfer(Invoker.java:127)
        at org.apache.qpid.tools.QpidBench.native_publisher(QpidBench.java:789)
        at org.apache.qpid.tools.QpidBench.access$500(QpidBench.java:45)
        at org.apache.qpid.tools.QpidBench$2.run(QpidBench.java:455)
Comment 4 errata-xmlrpc 2008-10-06 15:08:41 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0640.html

Note You need to log in before you can comment on or make changes to this bug.