Bug 459182 - RFE: No way to tell what is to be applied
RFE: No way to tell what is to be applied
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-14 16:18 EDT by James Antill
Modified: 2008-08-18 13:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-15 05:14:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Antill 2008-08-14 16:18:22 EDT
Description of problem:
 If you select some packages to be installed, there is no way to view "what will be done". Clicking apply and reading the confirm/deny boxes is it.
 Also the "additional packages needed" dialog doesn't tell you what the additional packages are needed for.
 Or give you any way to do anything but ok/cancel ... in fact if there are any problems it also just cancels the entire operation.

Version-Release number of selected component (if applicable):
gnome-packagekit.x86_64                  0.2.3-9.fc9            installed
Comment 1 Richard Hughes 2008-08-15 05:14:46 EDT
>there is no way to view "what will be done"

What's the use case? I don't think it's useful for the user to agree to the transaction at all. If there's tons of additional deps they can chicken out there.

>Also the ... dialog doesn't tell you what the additional packages are needed for.

Why is this useful?

The sort of people using the GUI tools won't be the yum cli users, but will be people like http://packagekit.org/pk-profiles.html -- where explaining why we want to download libssl-compat for libneon for k3b is just going to confuse all of them.

Richard.
Comment 2 James Antill 2008-08-18 13:47:43 EDT
> What's the use case?

 If you're installing/updating more than one thing at a time, the user shouldn't be expected to remember everything!
 You don't need to make it required reading, or even display it prominently. But I think it's a fairly basic thing that if you have 5 things queued to happen that you actually be able to see what they are.

> The sort of people using the GUI tools won't be the yum cli users, but 
> will be people like 

 So default to not showing anything at all then, or just a "additional packages are needed". And then a way to see what they are, and why they are needed.

 Or are you saying I should just give up using it because as a "yum cli user" PK will never be useful for people like me?

Note You need to log in before you can comment on or make changes to this bug.