Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 459196 - Gnome not starting without vga=0x318 on encrypted system
Summary: Gnome not starting without vga=0x318 on encrypted system
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: plymouth
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-08-14 21:37 UTC by Jerry Williams
Modified: 2008-10-14 16:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-14 16:52:42 UTC
Type: ---


Attachments (Terms of Use)
/var/log/messages can see 3rd reboot worked. (312.85 KB, text/plain)
2008-08-28 00:12 UTC, Jerry Williams
no flags Details

Description Jerry Williams 2008-08-14 21:37:12 UTC
Description of problem: If I don't have vga0x318 on kernel command line then Gnome doesn't start.


Version-Release number of selected component (if applicable):
plymouth-05.0-14.2008.08.08.fc10.i386
kernel-2.6.27-0.244.git1.fc10.i686


How reproducible: Always


Steps to Reproduce:
1. Boot with rhgb quiet
2. It boots with blue bar screen
3. Screen goes black and it asks for Password: and echo dots
4. Back to blue bar screen
5. Screen goes black and asks for Password: and echo dots
6. Back to Blue Bar screen.
7. Then see black screen with login: prompt and it flashes a bunch
8. Gnome never starts.


Actual results: Left at run level 3 login type screen.


Expected results: Should have Gnome login screen.


Additional info:

See lots of entries in /var/log/messages about:
localhost acpid: client has disconnected.

Have 3 partions on laptop
/boot
swap
/
swap and / are encrypted, no lvm.

If I change kernel command line from:
rhgb quiet
to
rhgb vga=0x31 quiet
Then I get the new screen and then lock for passwords.
Then black login: prompt screen and then Gnome starts.

Comment 1 Ray Strode [halfline] 2008-08-26 13:31:33 UTC
does logging in and running startx work?

Comment 2 Jerry Williams 2008-08-27 04:12:21 UTC
After firstboot finished I pushed Alt F1 and logged in as jwilliam.

Typed startx
xauth: creating new authority file /home/jwilliam/.serverauth.2775
xauth: creating new authority file /home/jwilliam/.Xauthority
xauth: creating new authority file /home/jwilliam/.Xauthority


Fatal server error:
Server is already active for display 0
        if this server is no longer running, remove /tmp/.X0-lock
        and start again.


And it just sits there, no prompt.

Alt F2 and login to another terminal.
ps -ef|grep tty1 
And I see:
startx calls
xinit which calls
root has [X] <defunct>

Reboot and Gnome comes up just fine.
So I guess it is only after firstboot.
Didn't have to add the vga=0x318

Comment 3 Ray Strode [halfline] 2008-08-27 14:06:42 UTC
So when you're erroneously at the "login: " screen, if you press ctrl-alt-f7 does it bring you GDM?

what about ctrl-alt-f8 or ctrl-alt-f9?

Comment 4 Jerry Williams 2008-08-28 00:12:31 UTC
Created attachment 315162 [details]
/var/log/messages can see 3rd reboot worked.

Comment 5 Jerry Williams 2008-08-28 00:15:42 UTC
Well How reproducible: Always isn't correct.
I have installed several times today.
And I had it work 1 time.
This last time I had to go through firstboot screens 3 times.
The first time the hard drive light just stayed on.
The second time the screen just went black and I couldn't find any keys that did anything.
The third time I hit alt F1 and got a prompt.
Then I tried ctrl-alt-f7 and that worked to get to the Gnome login.

I also tried to ping the box each time and the first 2 times it is like it would ping and then when the black screen came on it wouldn't ping.

I attached the messages file.
I am starting to think this might just be a network problem.

Comment 6 Ray Strode [halfline] 2008-09-29 18:06:47 UTC
Are you still seeing issues here?

Comment 7 Jerry Williams 2008-09-29 22:07:07 UTC
Not sure I can test this now with new kernel X Windows is broken.

Comment 8 Ray Strode [halfline] 2008-10-14 16:52:42 UTC
I think this is actually a duplicate of a firstboot bug that was fixed a while ago, so I'm going to close this out.

If it happens again though (after you X bug is resolved which I assume is happening on a different report), please reopen.


Note You need to log in before you can comment on or make changes to this bug.