Bug 459234 - If one option from ipa.conf is missing, the rest can get ignored
If one option from ipa.conf is missing, the rest can get ignored
Status: CLOSED ERRATA
Product: freeIPA
Classification: Community
Component: ipa-python (Show other bugs)
1.1
All Linux
low Severity low
: ---
: ---
Assigned To: Rob Crittenden
Chandrasekar Kannan
:
Depends On:
Blocks: 453489
  Show dependency treegraph
 
Reported: 2008-08-15 04:56 EDT by Martin Nagy
Modified: 2016-07-26 19:47 EDT (History)
6 users (show)

See Also:
Fixed In Version: freeipa-2.0.0-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-27 03:15:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Nagy 2008-08-15 04:56:09 EDT
Notice the server where the ipa-deluser is connecting. The server in dns is server.ipatest.com. I know you might think this is caused by Bug 458869 but it's not, because, even if it were, ipa-deluser would always connect to the same server.

# cat /etc/ipa/ipa.conf 
[defaults]
realm=IPATEST.COM
server=fake.ipatest.com
domain=ipatest.com

# ipa-deluser -v jdoe
Connecting to IPA server: https://fake.ipatest.com/ipa/xml
Could not initialize GSSAPI: An invalid name was supplied/Hostname cannot be canonicalized

# vim /etc/ipa/ipa.conf

# cat /etc/ipa/ipa.conf
[defaults]
#realm=IPATEST.COM
server=fake.ipatest.com
domain=ipatest.com

# ipa-deluser -v jdoe
Connecting to IPA server: https://server.ipatest.com/ipa/xml
Connecting to IPA server: https://server.ipatest.com/ipa/xml
[snip]
jdoe not found
Comment 1 Martin Nagy 2008-09-16 19:03:36 EDT
master: a9e8a72059ca5a6db13a9835d20f68dd16ce9a7a
Comment 2 Jenny Galipeau 2008-11-19 08:35:31 EST
fix verified:

[root@jennyv3 ~]# ipa-deluser -v tester
Connecting to IPA server: https://fake.bos.redhat.com/ipa/xml
Connecting to IPA server: https://fake.bos.redhat.com/ipa/xml
Could not initialize GSSAPI: An invalid name was supplied/Hostname cannot be canonicalized

Note You need to log in before you can comment on or make changes to this bug.