Bug 459260 - timed get on local queue doesn't actually timeout (RHEL4)
timed get on local queue doesn't actually timeout (RHEL4)
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.0
All Linux
urgent Severity high
: 1.0.1
: ---
Assigned To: messaging-bugs
Kim van der Riet
:
Depends On: 454854
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-15 09:30 EDT by Gordon Sim
Modified: 2011-08-12 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-06 14:59:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordon Sim 2008-08-15 09:30:59 EDT
+++ This bug was initially created as a clone of Bug #454854 +++

The underlying BlockingQueue::pop() keeps spinning on the empty check.

--- Additional comment from gsim@redhat.com on 2008-07-10 04:40:11 EDT ---

Fix committed to qpid trunk as r675477.

--- Additional comment from gsim@redhat.com on 2008-07-10 04:48:56 EDT ---

Target is provisionally 1.0.1, but the timed wait was intorduced since the GA
release so if that enhancement is not included in 1.0.1, this bug need not be
either.

--- Additional comment from gsim@redhat.com on 2008-07-10 10:45:03 EDT ---

merged to qpid.0-10 branch as r675598
Comment 2 Frantisek Reznicek 2008-09-17 03:39:50 EDT
RHTS test MRG_Messaging/qpid_localqueue_timeout_bz453599 results prove that bug has been fixed. (->VERIFIED)
Comment 4 errata-xmlrpc 2008-10-06 14:59:09 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0867.html

Note You need to log in before you can comment on or make changes to this bug.