Bug 45928 - Kudzu remove - with NC3131/7132 or NC3134/NC7132 combination
Kudzu remove - with NC3131/7132 or NC3134/NC7132 combination
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
: 45929 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-25 17:41 EDT by Bryan Leopard
Modified: 2014-03-16 22:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-28 10:05:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bryan Leopard 2001-06-25 17:41:59 EDT
Problem Statement:  Kudzu remove - with NC3131/7132 or NC3134/NC7132 
combination


How to view:
Install Red Hat 7.1 4-4-01 on ML350
After installation insert either NC3131 and NC7132 or NC3133 and NC7132
Boot server and use Kudzu installation option
Configure all IP address to users preference

Down server
Remove the NC3131/NC7132 or NC3134/NC7132

Boot the server and use the Kudzu option to remove the configuration.

Notice after the Kudzu remove that all the network configuration still 
exists in the Linuxconf utility.

Also notice that eth0 and eth3 still exists in the /etc/modules.conf file.

You should also notice that after the next reboot the network services for 
the now nonexistence card still tries to start.
Comment 1 Bryan Leopard 2001-06-28 10:05:38 EDT
More information

Please disregard my statement about the NC3133.  Replace with NC3134. 

Kudzu leaves files/configuration laying around after NICs are removed
on Red Hat Linux 7.1 kernel 2.4.2-2.


=============================================================================== 
/etc/module.conf after installing NICs - we only have five NICs in system (eth0
through eth4)
=============================================================================== 
alias eth0 e100
alias scsi_hostadapter cpqarray
alias parport_lowlevel parport_pc
alias eth1 eepro100
alias eth5 e1000

=============================================================================== 
configure network using netcfg and hand edit /etc/module.conf
=============================================================================== 
/proc/net/PRO_LAN_Adapters/eth0.info:PCI_Subsystem_ID          0xb163
/proc/net/PRO_LAN_Adapters/eth1.info:PCI_Subsystem_ID          0xb163
/proc/net/PRO_LAN_Adapters/eth2.info:PCI_Subsystem_ID          0xb134
/proc/net/PRO_LAN_Adapters/eth3.info:PCI_Subsystem_ID          0xb134
/proc/net/PRO_LAN_Adapters/eth4.info:PCI_Subsystem_ID          0x0049


alias eth0 e100
alias scsi_hostadapter cpqarray
alias parport_lowlevel parport_pc
alias eth4 e1000

Module                  Size  Used by
e1000                  48976   1 
e100                   44240   4 
nfsd                   69696   8  (autoclean)
lockd                  52464   1  (autoclean) [nfsd]
sunrpc                 61328   1  (autoclean) [nfsd lockd]
autofs                 11264   1  (autoclean)
cpqarray               16528   3 
sd_mod                 11680   0  (unused)
scsi_mod               95072   1  [sd_mod]

eth0      Link encap:Ethernet  HWaddr 00:50:8B:CF:AE:96  
          inet addr:10.10.10.1  Bcast:10.255.255.255  Mask:255.0.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:2 dropped:0 overruns:0 carrier:2
          collisions:0 txqueuelen:100 
          Interrupt:10 Base address:0x3000 Memory:c8843000-c8843c40 

eth1      Link encap:Ethernet  HWaddr 00:50:8B:CF:AE:97  
          inet addr:10.10.10.2  Bcast:10.255.255.255  Mask:255.0.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          Interrupt:11 Base address:0x3040 Memory:c8845000-c8845c40 

eth2      Link encap:Ethernet  HWaddr 00:01:FA:FF:7C:78  
          inet addr:10.10.10.3  Bcast:10.255.255.255  Mask:255.0.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:69 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          Interrupt:5 Base address:0x4000 Memory:c8847000-c8847c40 

eth3     Link encap:Ethernet  HWaddr 00:01:FA:FF:7C:77  
          inet addr:10.10.10.4  Bcast:10.255.255.255  Mask:255.0.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          Interrupt:7 Base address:0x4080 Memory:c8849000-c8849c40 

eth4      Link encap:Ethernet  HWaddr 00:08:C7:86:95:0B  
          inet addr:10.10.10.5  Bcast:10.255.255.255  Mask:255.0.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          Interrupt:10 Memory:c66e0000-c6700000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:52 errors:0 dropped:0 overruns:0 frame:0
          TX packets:52 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 



=============================================================================== 
power-down machine and remove NICs; kudzu leaves files/configuration laying
around...
=============================================================================== 

/proc/net/PRO_LAN_Adapters/eth0.info:PCI_Subsystem_ID          0xb134
/proc/net/PRO_LAN_Adapters/eth1.info:PCI_Subsystem_ID          0xb134

alias eth0 e100
alias scsi_hostadapter cpqarray
alias parport_lowlevel parport_pc
alias eth4 e1000

Module                  Size  Used by
soundcore               4464   0  (autoclean)
nfsd                   69696   8  (autoclean)
lockd                  52464   1  (autoclean) [nfsd]
sunrpc                 61328   1  (autoclean) [nfsd lockd]
autofs                 11264   1  (autoclean)
e100                   44240   2  (autoclean)
cpqarray               16528   3 
sd_mod                 11680   0  (unused)
scsi_mod               95072   1  [sd_mod]

eth0      Link encap:Ethernet  HWaddr 00:01:FA:FF:7C:78  
          inet addr:10.10.10.1  Bcast:10.255.255.255  Mask:255.0.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:50 errors:0 dropped:0 overruns:0 frame:0
          TX packets:21 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          Interrupt:5 Base address:0x3000 Memory:c8843000-c8843c40 

eth1      Link encap:Ethernet  HWaddr 00:01:FA:FF:7C:77  
          inet addr:10.10.10.2  Bcast:10.255.255.255  Mask:255.0.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          Interrupt:7 Base address:0x3080 Memory:c8845000-c8845c40 

lo        Link encap:Local Loopback  
  inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:52 errors:0 dropped:0 overruns:0 frame:0
          TX packets:52 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 

in /etc/sysconfig/network-scripts
ifcfg-eth0
ifcfg-eth1
ifcfg-eth2
ifcfg-eth3
ifcfg-eth4
ifcfg-irlan0
ifcfg-lo
ifdown
ifdown-cipcb
ifdown-ipv6
ifdown-post
ifdown-ppp
ifdown-sit
ifdown-sl
ifup
ifup-aliases
ifup-cipcb
ifup-ipv6
ifup-ipx
ifup-plip
ifup-plusb
ifup-post
ifup-ppp
ifup-routes
ifup-sit
ifup-sl
network-functions
network-functions-ipv6
Comment 2 Bill Nottingham 2001-06-28 11:14:43 EDT
If you don't use the supplied driver mappings, there is no way for the device
accounting to take care of this.
Comment 3 Bill Nottingham 2001-06-28 11:14:56 EDT
*** Bug 45929 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.