Bug 459283 - coreutils 6.10 30.fc9 breaks ls --color=auto
coreutils 6.10 30.fc9 breaks ls --color=auto
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-15 14:08 EDT by Joel
Modified: 2008-09-05 05:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-05 05:11:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joel 2008-08-15 14:08:54 EDT
Description of problem:

new version of coreutils triggered probelm with ls giving LS_COLORS errors:

$ \ls --color=auto -l --context
ls: unrecognized prefix: ca
ls: unparsable value for LS_COLORS environment variable
drwxrwx---  jdyoung jdyoung unconfined_u:object_r:user_home_t edu


Version-Release number of selected component (if applicable):
coreutils 6.10 30.fc9


How reproducible:

type ls as above (or any ls command using color in certain directories).

 
Actual results:

See message above

Expected results:

Colored output


Additional info:
$ echo $LS_COLORS 
no=00:fi=00:di=00;34:ln=00;36:pi=40;33:so=00;35:do=00;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=00;32:*.cmd=00;32:*.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=00;32:*.tar=00;31:*.tgz=00;31:*.svgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.lzma=00;31:*.zip=00;31:*.z=00;31:*.Z=00;31:*.dz=00;31:*.gz=00;31:*.bz2=00;31:*.tbz2=00;31:*.bz=00;31:*.tz=00;31:*.deb=00;31:*.rpm=00;31:*.jar=00;31:*.rar=00;31:*.ace=00;31:*.zoo=00;31:*.cpio=00;31:*.7z=00;31:*.rz=00;31:*.jpg=00;35:*.jpeg=00;35:*.gif=00;35:*.bmp=00;35:*.pbm=00;35:*.pgm=00;35:*.ppm=00;35:*.tga=00;35:*.xbm=00;35:*.xpm=00;35:*.tif=00;35:*.tiff=00;35:*.png=00;35:*.mng=00;35:*.pcx=00;35:*.mov=00;35:*.mpg=00;35:*.mpeg=00;35:*.m2v=00;35:*.mkv=00;35:*.ogm=00;35:*.mp4=00;35:*.m4v=00;35:*.mp4v=00;35:*.vob=00;35:*.qt=00;35:*.nuv=00;35:*.wmv=00;35:*.asf=00;35:*.rm=00;35:*.rmvb=00;35:*.flc=00;35:*.avi=00;35:*.fli=00;35:*.gl=00;35:*.dl=00;35:*.xcf=00;35:*.xwd=00;35:*.yuv=00;35:*.svg=00;35:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:
Comment 1 Gianluca Varisco 2008-08-15 15:59:54 EDT
(In reply to comment #0)
> Description of problem:
> 
> new version of coreutils triggered probelm with ls giving LS_COLORS errors:
> 
> $ \ls --color=auto -l --context
> ls: unrecognized prefix: ca
> ls: unparsable value for LS_COLORS environment variable
> drwxrwx---  jdyoung jdyoung unconfined_u:object_r:user_home_t edu
> 

I had the same problem, but after a 'source ~/.bash_profile' I fixed it. Did you try to reload bash_profile stuffs?
Comment 2 Joel 2008-08-15 17:41:07 EDT
I hadn't tried it.  And yes, that did work.  Thanks for the work-around!
Comment 3 Ondrej Vasik 2008-08-17 11:58:24 EDT
Thanks for report. Problem caused by removal of updated ls. Capability prefix was added to LS_COLORS at coreutils-6.10-28.fc9 , but due to bug in tcsh (see #457342) it was removed quickly in coreutils-6.10-30.fc9. What you see is caused by the fact that bash{whatever shell) session has old LS_COLORS from coreutils-6.10-28.fc9 but "new" ls from coreutils-6.10-30.fc9 . This could be fixed by shipping ls with capability support but with no capability prefix in dircolors files. Will do that in next F9 update although I guess it will be already fixed on most of the machines (as it should not happen in new shell session).

Note You need to log in before you can comment on or make changes to this bug.