Bug 45931 - (ATI Rage 128 Mobility M4) Lockup when screensaver kicks in
(ATI Rage 128 Mobility M4) Lockup when screensaver kicks in
Status: CLOSED DUPLICATE of bug 37074
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-25 18:28 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-25 18:28:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-06-25 18:28:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3 i686)

Description of problem:
trying to 'startx' on a Dell latitude C800 w/ C/Dock II kills the OS

How reproducible:
Always

Steps to Reproduce:
1.startx
2.
3.
	

Actual Results:  The screen goes blank and the kernel hangs...nothing
responds.

Expected Results:  X windows should appear and greet me with a fun GUI.

Additional info:

When the laptop is not in the docking station it sarts x fine, once the
laptop is put in the docking station the problem occurs...'startx' freezes
the machine entirely. No log files are created at all.

My XF86Conifg file:

Section "ServerLayout"
        Identifier "XFree86 Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

# By default, Red Hat Linux 6.0 and later use xfs

Section "Files"
        FontPath "unix/:7100"
EndSection

# This loads all the modules...

Section "Module"
        Load  "GLcore"
        Load  "dbe"
        Load  "dri"
        Load  "extmod"
        Load  "glx"
        Load  "pex5"
        Load  "record"
        Load  "xie"
        Load  "v4l"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "keyboard"
        Option      "XkbLayout" "us"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Device" "/dev/mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Emulate3Buttons" "on"
        Option      "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
        Identifier "Dell P1110"
        VendorName "Unknown"
        ModelName  "Unknown"
        HorizSync 30.0-121.0
        VertRefresh 48.0-160.0
        Option "dpms"
EndSection

Section "Device"
        Identifier "ATI|Rage Mobility M3 AGP 2x"
        Driver "r128"
        BoardName "Unknown"
        Option  "AGPMode" "2"
        Option  "Display" "Mirror"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device "ATI|Rage Mobility M3 AGP 2x"
        Monitor "Dell P1110"
        DefaultDepth 24
        Subsection "Display"
                Depth 32 
                Modes "1600x1200"
        EndSubSection
        Subsection "Display"
                Depth 24
                Modes "1600x1200"
        EndSubSection
EndSection

Section "DRI"
EndSection
Comment 1 Mike A. Harris 2001-08-15 22:13:39 EDT
Your resolution and bit depth combined consume way to much video
memory for DRI to operate correctly.  Either disable DRI, or
lower your resolution and/or bit depth down to something that
this hardware and X support.

*** This bug has been marked as a duplicate of 37074 ***

Note You need to log in before you can comment on or make changes to this bug.