Bug 459310 - anaconda detects insufficient space for image on HD, but back button continues
anaconda detects insufficient space for image on HD, but back button continues
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-15 20:36 EDT by Geoff Gustafson
Modified: 2008-11-21 00:54 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-21 00:54:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geoff Gustafson 2008-08-15 20:36:06 EDT
Description of problem:
I installed an F9 Live image to a USB flash drive. I booted it on a new Asus Eee PC 901. Then I clicked the Install to Hard Drive icon which launched anaconda. It had Windows installed already with a 3GB sda and 7GB sdb. I wanted to shrink sdb and install there. I told it to use 2GB, thought that was the size I was shrinking, but maybe that was the size of the new partition? Later it complained that 2GB wasn't enough space, but when I hit "Back" it went ahead and tried.

Also, this Eee PC has 1024x600 resolution. Anaconda starts up in a small window, and the controls often don't really fit in the window... it should at least make use of the full vertical screen available.

While you're at it, grep the source for "instalation" and correct it to "installation" -- there was an error message with that typo.

Version-Release number of selected component (if applicable):
F9 Live image on USB
anaconda-11.4.0.82-1.i386

How reproducible:
Only tried once

Steps to Reproduce:
1. Create USB image
2. Boot on Asus Eee PC 901
3. Try to install to hard drive, resizing partition sdb1 from 7 to 2 GB
  
Actual results:
Complains that 2GB isn't enough, then gives a dialog with a back button. When you click 'back' it goes ahead and starts copying the image to the hard drive. About 90% through the progress bar, it dies with an error about no space left on device.

Expected results:
Back should go back, not continue on the path to doom.

Additional info:
Comment 1 Chris Lumens 2008-08-26 13:50:10 EDT
Can you please give F10 Alpha a try?  There's been some work done in the code around copying the installation image, which I think has a good possibility of fixing this.  Thanks.
Comment 2 David Cantrell 2008-11-21 00:54:51 EST
Looks like we've fixed this up.

Note You need to log in before you can comment on or make changes to this bug.