Bug 459332 - Broken € (euro sign) for LY1-encoded fonts (texnansx.enc)
Broken € (euro sign) for LY1-encoded fonts (texnansx.enc)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: texlive-texmf (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-16 13:02 EDT by Vasile Gaburici
Modified: 2013-07-02 19:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-21 05:59:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vasile Gaburici 2008-08-16 13:02:46 EDT
The buggy entry is /Uni20AC in texnansx.enc. This does not work with any PostScript font I know of. According to the AGL (Adobe Glyph List) and naming conventions either /uni20AC or /Euro should work. I've changed it to /uni20AC and now I get the euro for LY1-encoded fonts.

I've notified upstream by email (i.e. tex-live@tug.org) since they've got no other bug tracker.
Comment 1 Vasile Gaburici 2008-08-16 17:26:03 EDT
(In reply to comment #0)
> The buggy entry is /Uni20AC in texnansx.enc. This does not work with any
> PostScript font I know of. According to the AGL (Adobe Glyph List) and naming
> conventions either /uni20AC or /Euro should work. I've changed it to /uni20AC
> and now I get the euro for LY1-encoded fonts.
> 
> I've notified upstream by email (i.e. tex-live@tug.org) since they've got no
> other bug tracker.

Upstream agreed to change it to /Euro.
Comment 2 Jindrich Novy 2008-08-27 09:49:07 EDT
Applied. Thanks. The /Euro seems to be less cryptic and more compatible.
Comment 3 Jindrich Novy 2008-10-15 06:07:58 EDT
Please test the following update if you have a while:
https://admin.fedoraproject.org/updates/texlive-2007-32.fc9,texlive-texmf-2007-24.fc9

It should finally fix this and couple of other issues :)
Comment 4 Fedora Update System 2008-10-20 16:29:42 EDT
texlive-texmf-2007-24.fc9, texlive-2007-32.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update texlive-texmf texlive'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8931
Comment 5 Fedora Update System 2008-11-21 05:58:36 EST
texlive-texmf-2007-24.fc9, texlive-2007-32.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.