Bug 459385 - kdump failed with dm-multipath
kdump failed with dm-multipath
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Neil Horman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-18 06:46 EDT by masanari iida
Modified: 2008-08-18 07:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-18 07:27:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description masanari iida 2008-08-18 06:46:12 EDT
Description of problem:
If I install os with "linux mpath" and configure kdump (diskdump),
it faild to save vmcore. 
It was because 2nd kernel failed to initialize dm-multipath disk.


Version-Release number of selected component (if applicable):
RHEL5 ( 2.6.18-53.el5 )
kexec-tools-1.101-194.4.el5

How reproducible:
Always

Steps to Reproduce:
1. Install OS with dm-multipath.
2. Configure kdump (diskdump).
3. Crash the system with echo "c" > /proc/sysrq-trigger 
  
Actual results:
kdump failed. Stop with shell prompto.

Expected results:
kdump success and vmcore file is saved.


Additional info:

# multipath -ll
mpath0 (3600508b40005531d0000900000110000) dm-0 HP,HSV200
[size=60G][features=1 queue_if_no_path][hwhandler=0]
\_ round-robin 0 [prio=200][active]
 \_ 0:0:0:3 sda 8:0   [active][ready]
 \_ 0:0:1:3 sdb 8:16  [active][ready]
 \_ 1:0:0:3 sde 8:64  [active][ready]
 \_ 1:0:1:3 sdf 8:80  [active][ready]
\_ round-robin 0 [prio=40][enabled]
 \_ 0:0:2:3 sdc 8:32  [active][ready]
 \_ 0:0:3:3 sdd 8:48  [active][ready]
 \_ 1:0:2:3 sdg 8:96  [active][ready]
 \_ 1:0:3:3 sdh 8:112 [active][ready]


# cat /proc/mdstat
Personalities :
unused devices: <none>


# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/mpath0p2  30470176   2086280  26811136   8% /
/dev/mapper/mpath0p1    101086     17923     77944  19% /boot
tmpfs                   452104         0    452104   0% /dev/shm
/dev/mapper/mpath0p4   3945160     73448   3671304   2% /var/crash


# /etc/kdump.conf
ext3 /dev/mapper/mpath0p4


Points to consider.
(1) This is a SAN boot system.
If I don't set dm-multipath, the system's device file is /dev/sda.
In that case, I confirm the kdump works as expected.

(2) If I set dm-multipath at install time and configure kdump.
initrd-<version>kdump.img which was created by mkdumprd 
does NOT include dm-multipath related commands.

(3) As I see inside of the /sbin/mkdumprd script,
it does check /proc/mdstat.  
But my mdstat doesn't contain any information about level.
I guess it is because this script checks md-raid multipath,
insted of dm-multipath.  Confusing!

     levels=$(grep "^$1[  ]*:" /proc/mdstat | \     <==
        awk '{ print $4 }')
    devs=$(grep "^$1[    ]*:" /proc/mdstat | \
        awk '{ print gensub("\\[[0-9]*\\]","","g",gensub("^md.*raid[0-9]*","","1")) }')

    for level in $levels ; do
        case $level in
        linear)
            findmodule linear
            start=1
            ;;
        multipath)                        <<== 
            findmodule multipath
            start=1
            ;;


I expect RH followings.
(1) Man, Release Note and README file should state if mkdumprd 
support which type of multipath.

(2) If kdump with dm-multipath environment is not supported,
I expect to enhance the function.
Comment 1 Neil Horman 2008-08-18 07:27:17 EDT
kdump will not be supporting  multipath any time soon ( see bz's 442550 and 222992).  We should have an entryin our knoweldgebase indicating that multipath ins't safely supportable.  I'm not planning on adding this feature to kexec any time in the near future.

Note You need to log in before you can comment on or make changes to this bug.