Bug 459489 - occasional assert in gtk_progress_set_percentage (fraction out of range) when doing updates
occasional assert in gtk_progress_set_percentage (fraction out of range) when...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pirut (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: James Antill
Petr Sklenar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-19 07:58 EDT by Vladimir Benes
Modified: 2013-04-15 04:58 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-20 05:14:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vladimir Benes 2008-08-19 07:58:46 EDT
Description of problem:
crash while updating software but only sometimes
I am writing pirut dogtail script and pirut crashes sometimes while updating packages (installing docbook-slides with deps)

Version-Release number of selected component (if applicable):
pirut-1.3.28-13.el5

How reproducible:


Steps to Reproduce:
1.click app -> check authoring and publishing 
2.uncheck all -> go in and then check first
3.add some deps and when updating soft -> crash (occasional)
  
Actual results:
occasional crash

Expected results:
never crash

Additional info:

/usr/sbin/pirut:422: Warning: IA__g_object_weak_unref: couldn't find weak ref 0x31f2a51770(0x2b05c9a723c0)
  gtk.main()
/usr/lib/python2.4/site-packages/pirut/Progress.py:91: GtkWarning: gtk_progress_set_percentage: assertion `percentage >= 0 && percentage <= 1.0' failed
  self.pbar.set_fraction(fract)

not using consolehelper because it destroys accessibility
Comment 1 James Antill 2008-09-26 00:45:29 EDT
this shoudn't be hard to work around the hacky way (just limit it before the call).
 might as well add it to the 5.4 fast bugs.
Comment 9 Vladimir Benes 2010-01-13 11:22:11 EST
Just a thought: as it was originally reported to 5.2 maybe something updated in 5.3 fixed that.
Comment 10 James Antill 2010-01-13 11:50:01 EST
Maybe it was. I didn't reproduce it ... I just worked around the problem (never pass a bad number to gtk, even if we get one).
Comment 11 Petr Sklenar 2010-01-14 04:49:12 EST
(In reply to comment #9) & (In reply to comment #10)
yeap :) , it can see that in rhel5U2 only, thx much
Comment 14 errata-xmlrpc 2010-01-20 05:14:54 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0058.html

Note You need to log in before you can comment on or make changes to this bug.