Bug 459688 - (NoK0mm3nt) iwl4965-firmware conflicts with kernel-2.6.25.14-108.fc9.i686
iwl4965-firmware conflicts with kernel-2.6.25.14-108.fc9.i686
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: iwl4965-firmware (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nicolas Chauvet (kwizart)
Fedora Extras Quality Assurance
: Reopened
: 468767 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-21 04:35 EDT by danmcg.au
Modified: 2014-01-21 18:06 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-12 12:19:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description danmcg.au 2008-08-21 04:35:56 EDT
Description of problem:

iwl4965-firmware conflicts with kernel-2.6.25.14-108.fc9.i686

Version-Release number of selected component (if applicable):

iwl4965-firmware -> 228.57.2.21-1
kernel -> 2.6.25.14-108.fc9.i686

How reproducible:

Attempting to update to the new kernel with PackageKit

Steps to Reproduce:
1.
2.
3.
  
Actual results:

ERROR with rpm_check_debug vs depsolve:
iwl4965-firmware conflicts with kernel-2.6.25.14-108.fc9.i686
Please report this error in bugzilla


Expected results:


Additional info:
Comment 1 John W. Linville 2008-08-21 11:24:53 EDT
Fedora infrastructure is still a bit broken, so I can't do a lot of investigation ATM...

Did you try "yum update iwl4965-firmware" _before_ "yum update kernel"?  If that doesn't work, what about the opposite order?
Comment 2 danmcg.au 2008-08-22 04:17:50 EDT
Yes

[root@localhost ~]# yum update iwl4965-firmware
Loaded plugins: refresh-packagekit
Setting up Update Process
Could not find update match for iwl4965-firmware
No Packages marked for Update
[root@localhost ~]# yum update kernel
Loaded plugins: refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package kernel.i686 0:2.6.25.14-108.fc9 set to be installed
--> Processing Conflict: kernel conflicts iwl4965-firmware < 228.57.2
--> Finished Dependency Resolution
kernel-2.6.25.14-108.fc9.i686 from updates has depsolving problems
  --> kernel conflicts with iwl4965-firmware
--> Running transaction check
---> Package kernel.i686 0:2.6.25-14.fc9 set to be erased
--> Finished Dependency Resolution


iwl4965-firmware is the latest version available.

Regards
Comment 3 John W. Linville 2008-08-22 09:46:32 EDT
What is the output of "rpm -q iwl4965-firmware"?  For me:

   iwl4965-firmware-228.57.2.21-1

But mine didn't get there through yum -- it is possible there is some hiccup in the package release process...
Comment 4 danmcg.au 2008-08-22 10:01:35 EDT
iwl4965-firmware-4.44.1.20-1.noarch
iwl4965-firmware-228.57.2.21-1.noarch

Hmmm
Comment 5 John W. Linville 2008-08-22 13:16:36 EDT
Interesting...can you "yum erase iwl4965-firmware-4.44.1.20-1"?  Then "yum update"?
Comment 6 danmcg.au 2008-08-22 17:12:10 EDT
Installed: kernel.i686 0:2.6.25.14-108.fc9

iwl-4.44 didn't come back.
Comment 7 John W. Linville 2008-08-22 17:24:06 EDT
I have no idea what happened here or what can be done to avoid it in the future, but I suspect that this is a packaging issue.
Comment 8 Nicolas Chauvet (kwizart) 2008-08-23 04:59:05 EDT
*** Bug 459799 has been marked as a duplicate of this bug. ***
Comment 9 IBM Bug Proxy 2008-08-23 05:02:39 EDT
=Comment: #0=================================================
Arnd Bergmann <arndb@de.ibm.com> - 2008-08-21 05:56 EDT
Fedora 9 ships with a version of iwl4965-firmware that is incompatible with
current kernels. The package has been removed on rawhide/ppc but is still
getting installed by default in the fedora 9 installer.

F9 update kernels now have a conflict with older versions of the package,
preventing updates without removing an existing package first.
I suggest providing the updated iwl4965-firmware package on powerpc as well to
avoid this problem. This seems to be the solution that was used on F-8.

reassigning to iwl4965-firmware

*** This bug has been marked as a duplicate of 459688 ***
Comment 10 Arnd Bergmann 2008-08-25 03:31:57 EDT
Please note that the specific problem that I reported is a powerpc and cannot happen on i386, so bug #459688 is not strictly a duplicate of this one, though there may be a common solution.
Comment 11 Nicolas Chauvet (kwizart) 2008-09-05 06:21:27 EDT
(In reply to comment #7)
> I have no idea what happened here or what can be done to avoid it in the
> future, but I suspect that this is a packaging issue.
The ppc side of the problem have is been solved. for this particular bug, i guess this is a problem with iwl4965-firmware been installed in two versions. (rpm -ivh instead of rpm -Uvh ?)

I don't know if there is a yum-plugin to handle parallelle installation of packages. But it shoudn't have worked.
Comment 12 Nicolas Chauvet (kwizart) 2008-09-15 06:16:36 EDT
I don't know who closed this bug. (If it is me, that was a misstake)
The problem still appear and is caused by the parallele installation of both version of the iwl4965-firmware (one from the stable repo, and the other from updates). 
At least, that's what I expect
Comment 13 IBM Bug Proxy 2008-10-06 10:38:07 EDT
Redhat,  Any update on this bug?
Comment 14 Nicolas Chauvet (kwizart) 2008-10-06 11:35:29 EDT
Does the problem still occurs ?
Do you have the iwl4965-firmware installed twice ?
Comment 15 Nicolas Chauvet (kwizart) 2008-10-28 04:45:11 EDT
*** Bug 468767 has been marked as a duplicate of this bug. ***
Comment 16 James Antill 2008-10-28 11:03:37 EDT
Can you try:

package-cleanup --dups

...and/or:

yum-complete-transaction
Comment 17 Nicolas Chauvet (kwizart) 2008-10-28 11:16:50 EDT
According to the IRC talk with tibbs and linville of today.
It can be a problem  with yum not handling Conflict accurately. (as the iwl4965-firmware ends to be installed twice whereas it just need to be updated).

If the yum maintainers tell they don't feel concerned by the bug.
please either re-assign to:
 - kernel: the conflict is aimed to force the iwl4965-firmware update for people that only update the kernel without having the whole update repository selected (where iwl4965-firmware will be missing). This is a rare case, but produces a side effect in the common case.
Thus this hack should be avoided.

 - meta: Distribution: This bug will hence be dispatched at the whole distro level.
Comment 18 seth vidal 2008-10-28 11:27:00 EDT
Is there a file conflict here or an explicit packaging conflict?
Comment 19 Nicolas Chauvet (kwizart) 2008-10-28 11:36:58 EDT
(In reply to comment #18)
> Is there a file conflict here or an explicit packaging conflict?
This is a package conflict against a previous version of iwl495-firmware(as seen in the current kernel-2.6.spec )
Comment 20 James Antill 2008-10-28 12:06:22 EDT
> According to the IRC talk with tibbs and linville of today.
> It can be a problem  with yum not handling Conflict accurately. (as the
> iwl4965-firmware ends to be installed twice whereas it just need to be
> updated).

If this is true, then it's a bug ... but I haven't seen that before. What I have seen is "yum update" + stop half way thourgh leaves 2 packages installed. yum-complete-transaction should solve that (and recent yums will point out that it should be run).

Obviously if you have a reproducer that shows yum doing weird things on updates with conflicts feel free to post info.
Comment 21 IBM Bug Proxy 2008-12-04 09:41:37 EST
Any update on this bug?
Comment 22 Ian Durston 2008-12-05 13:16:47 EST
I individually selected the updates, so it updated each thing in a different order and it seemed to work.......
Comment 23 IBM Bug Proxy 2009-01-12 11:40:41 EST
iwl4965-firmware-228.57.2.23-1.fc9.noarch.rpm is now in the ppc updates directory for f9, so this bug can be closed.
Comment 24 Nicolas Chauvet (kwizart) 2009-01-12 12:18:40 EST
Closing as iwl465-firmware since it was actually a problem with the package not moved to the F-9 repos from a F-8 built despite the request was made to rel-eng.

Note You need to log in before you can comment on or make changes to this bug.