Bug 459753 - yum.conf does not appear to accept exclude directive with file globbing.
yum.conf does not appear to accept exclude directive with file globbing.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-21 17:22 EDT by Greg Metcalfe
Modified: 2014-01-21 18:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-21 17:55:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Metcalfe 2008-08-21 17:22:25 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.16) Gecko/20080715 Fedora/2.0.0.16-1.fc8 Firefox/2.0.0.16

man(5) yum.conf says * and ? will work in an exclude. I added an exclude, and my
exclude looks like this:
 $ cat yum.conf
[main]
cachedir=/var/cache/yum
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
exlude=*fglrx*
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
metadata_expire=1800
installonly_limit=2

as the fglrx does not work with my graphics/card combo. Ran 'sync', then 'yum update, and saw the following:
# yum update
Loading "protectbase" plugin
Loading "protect-packages" plugin
0 packages excluded due to repository protections
Setting up Update Process
No Packages marked for Update

$ rpm -qa | grep fglrx
xorg-x11-drv-fglrx-8.512-1.8.07.lvn8
xorg-x11-drv-fglrx-libs-8.512-1.8.07.lvn8
kmod-fglrx-8.512-2.8.07.lvn8
kmod-fglrx-2.6.25.14-69.fc8-8.512-2.8.07.lvn8
kmod-fglrx-2.6.25.11-60.fc8-8.512-1.8.07.lvn8

This is not encouraging. Hardware is aging, but not archaic (ATI Radeon 9000, Princeton VL19 19" LCD). Having to edit xorg.conf to specify "radeon" vice "fglrx" to get a runlevel, as I've had to do since the last time 
livna updated their fglrx packages, get old.

The packages could actually be protected, and only what yum displays is incorrect. Troubleshooting ideas welcome, as I either have to wait for next fglrx update, on an unknown timeline, or do potentially large package rollbacks. Hence the next unsatisfactory but truthful entry(s).

Reproducible: Didn't try

Steps to Reproduce:
1.
2.
3.
Comment 1 Seth Vidal 2008-08-21 17:55:28 EDT
you have a typo your exclude option is being spelled:
exlude
Comment 2 Greg Metcalfe 2008-08-21 18:09:32 EDT
Duh. Tested, works as advertised.

With all the typos in the bug report, makes me look like an idiot. With my usual browser (KDE Konqueror) I couldn't find the submit a new bug link--just endless searches. Maybe a Javascript issue, which Konq has problems with, or I might have missed something. Using Firefox, I went right to it. But the data-entry text was microscopically small. Hence the typos. Sigh.

Sorru to hve wastd yor time. I uzualy spel gud.

Note You need to log in before you can comment on or make changes to this bug.