Bug 459785 - Cannot recognize jp106 at keyboard selection when booting rescue mode.
Cannot recognize jp106 at keyboard selection when booting rescue mode.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.9
All Linux
medium Severity medium
: rc
: ---
Assigned To: Radek Vykydal
Release Test Team
: OtherQA, Regression
Depends On:
Blocks: 500640
  Show dependency treegraph
 
Reported: 2008-08-22 06:55 EDT by Adam Stokes
Modified: 2009-05-13 10:13 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Japanese language JP106 keyboards will not function correctly when booting into Rescue Mode on Red Hat Enterprise Linux 4.8.
Story Points: ---
Clone Of:
: 500640 (view as bug list)
Environment:
Last Closed: 2009-05-06 07:08:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Joel Andres Granados 2008-09-24 08:50:11 EDT
We might be able to avoid this if we check for /proc/xen/capabilities.  it was a change done for rhel5. might work here.  Assigning this just in case we can sneak it in for rhel4.8.
Comment 3 RHEL Product and Program Management 2008-10-02 06:35:45 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Radek Vykydal 2009-01-08 07:28:31 EST
Fixed with commit fd4fe3801e1e747f155440b326190efe8bf26407.
Should go to 10.1.1.92.
Comment 8 Alexander Todorov 2009-03-13 08:55:16 EDT
ping

Can we get some feeback here? RTT doesn't have jp106 keyboard so we can't test this.
Comment 9 Radek Vykydal 2009-03-13 09:06:09 EDT
I think the bug should be reproducible with any non-us entry from
the keyboard list.
Comment 11 Radek Vykydal 2009-04-14 07:58:20 EDT
Strange, I do see it with nightly 04-13 (in vmware VM),
the only thing I can think of now is that you have the
keyboard selected in kickstart file?
Comment 12 Alexander Todorov 2009-04-14 08:19:07 EDT
It's rescue mode. It doesn't use kickstart files. It's bare metal + serial console connection. Does this matter?
Comment 13 Radek Vykydal 2009-04-14 09:19:03 EDT
Yes, there is no keyboard selection screen in serial console mode,
I think you can use keymap= command line option instead to test the
fix.
Comment 22 Larry Troan 2009-04-28 21:45:10 EDT
On Tue, 2009-04-28 at 16:07 -0400, Yujin Yamazaki wrote:
> Larry,
> 
> I validated this fix on RHEL4.8-Snapshot5 with jp106 keyboard
> in Westford office, though it seems that this bug has not been
> fixed yet. If you have any suggestions, please let me know.
> 
> ----------------------------------------
> Test environment:
>  - Version: RHEL4.8 (Snapshot5)
>  - Kernel Version: 2.6.9-88
>  - Hardware Model: PRIMERGY TX200 S2 (x86_64)
>  - Keyboard: jp106
> ----------------------------------------
> 
> Thank you,
> 
> Yujin Yamazaki, FUJITSU on-site in Westford
>
Comment 26 Denise Dumas 2009-04-30 15:06:00 EDT
Since this is rescue mode, and since RC2 is already spun, we're not going to hold the release for it. We'll add a release note and move this to 4.9. But we need to complete the work and get the patch ready while we have access to one of these keyboards.
Comment 27 Denise Dumas 2009-04-30 15:06:00 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
When using Rescue Mode with a Japanese language JP106 keyboard, the keyboard will not be recognized.
Comment 30 Joel Andres Granados 2009-05-06 07:08:02 EDT
Release note is intended for rhel4.8.  Since its going to be a release note this bug can be closed.
Comment 32 Ryan Lerch 2009-05-07 18:06:23 EDT
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1 @@
-When using Rescue Mode with a Japanese language JP106 keyboard, the keyboard will not be recognized.+Japanese language JP106 keyboards will not function correctly when booting into Rescue Mode on Red Hat Enterprise Linux 4.8.
Comment 33 Ryan Lerch 2009-05-07 18:29:27 EDT
this note is now in the 4.8 Release Notes document.
a test build of this document can be viewed (internally) here:
http://graphics.bne.redhat.com/rhel4/RELEASE-NOTES-U8-test-en.html

Note You need to log in before you can comment on or make changes to this bug.