Bug 459791 - virDomainCreateLinux() failed internal error Failure while reading monitor startup output: Input/output error
virDomainCreateLinux() failed internal error Failure while reading monitor st...
Status: CLOSED DUPLICATE of bug 454616
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-08-22 08:32 EDT by Ahmed Medhat
Modified: 2008-08-26 14:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-08-22 09:31:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
/root/.virtinst/virt-install.log (1.39 KB, application/x-bzip)
2008-08-22 08:32 EDT, Ahmed Medhat
no flags Details

  None (edit)
Description Ahmed Medhat 2008-08-22 08:32:40 EDT
Created attachment 314794 [details]

Description of problem:

I had the bug previously reported under https://bugzilla.redhat.com/show_bug.cgi?id=453260 , I applied the suggested patch and I got another problem and this is under virtinst and virt-manager so I assume its a libvirt issue.

Version-Release number of selected component (if applicable):


How reproducible:

On a Fedora 9 x86_64, Apply patch under https://bugzilla.redhat.com/show_bug.cgi?id=453260 and try to install a new Paravirtualized virtual machine.

Steps to Reproduce:

What is the name of your virtual machine? node06
 How much RAM should be allocated (in megabytes)? 256
 What would you like to use as the disk (file path)? /dev/vg00/node06
 Would you like to enable graphics support? (yes or no) no
 What is the install location? http://styx.biochem.wfubmc.edu/mirror/CentOS/5.2/os/x86_64/               

Actual results:

virDomainCreateLinux() failed internal error Failure while reading monitor startup output: Input/output error
Domain installation may not have been
 successful.  If it was, you can restart your domain
 by running 'virsh start node06'; otherwise, please
 restart your installation.
Fri, 22 Aug 2008 15:25:27 ERROR    virDomainCreateLinux() failed internal error Failure while reading monitor startup output: Input/output error
Traceback (most recent call last):
  File "/usr/sbin/virt-install", line 497, in <module>
  File "/usr/sbin/virt-install", line 457, in main
    dom = guest.start_install(conscb,progresscb)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 845, in start_install
    return self._do_install(consolecb, meter)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 866, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib64/python2.5/site-packages/libvirt.py", line 841, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: virDomainCreateLinux() failed internal error Failure while reading monitor startup output: Input/output error

Expected results:

To start the virtual machine installation process.
Comment 1 Daniel Berrange 2008-08-22 08:42:29 EDT
Can you provide the /var/log/libvirt/qemu/node06.log file for me
Comment 2 Ahmed Medhat 2008-08-22 09:22:17 EDT
Sure, Below is the output from the requested file.

/usr/bin/xenner -S -M xenner -m 256 -smp 1 -name node06 -nographic -monitor pty -no-acpi -boot c -kernel /var/lib/libvirt/boot/virtinst-vmlinuz.MT907W -initrd /var/lib/libvirt/boot/virtinst-initrd.img.TOFI4B -append  method=http://styx.biochem.wfubmc.edu/mirror/CentOS/5.2/os/x86_64/ -drive file=/dev/vg00/node06,if=xen,index=0 -net nic,macaddr=00:16:3e:32:83:75,vlan=0 -net tap,fd=30,script=,vlan=0,ifname=vnet9 -serial none -parallel none -usb 
[xenner,1] qemu_monitor_config: pty
[xenner,1] qemu_monitor_config: /dev/pts/15
char device redirected to /dev/pts/15
[xenner,1] qemu_serial_config: none
[xenner,1] qemu_disk_config_blkbackd: file=/dev/vg00/node06,if=xen,index=0
[xenner,1] qemu_net_config_netbackd: nic,macaddr=00:16:3e:32:83:75,vlan=0
[xenner,1] qemu_net_config_netbackd: 0: mac="00:16:3e:32:83:75"
[xenner,1] qemu_net_config_netbackd: tap,fd=30,script=,vlan=0,ifname=vnet9
[xenner,1] qemu_net_config_netbackd: 0: if="vnet9"
started as: "/usr/bin/xenner" "-S" "-M" "xenner" "-m" "256" "-smp" "1" "-name" "node06" "-nographic" "-monitor" "pty" "-no-acpi" "-boot" "c" "-kernel" "/var/lib/libvirt/boot/virtinst-vmlinuz.MT907W" "-initrd" "/var/lib/libvirt/boot/virtinst-initrd.img.TOFI4B" "-append" " method=http://styx.biochem.wfubmc.edu/mirror/CentOS/5.2/os/x86_64/" "-drive" "file=/dev/vg00/node06,if=xen,index=0" "-net" "nic,macaddr=00:16:3e:32:83:75,vlan=0" "-net" "tap,fd=30,script=,vlan=0,ifname=vnet9" "-serial" "none" "-parallel" "none" "-usb"
kvm capability clocksource: not supported
kvm capability nop-iodelay: not supported
kvm capability mmu-op: not supported
open /var/run/xenner/vmcore.16928: No such file or directory
xenner_cleanup: ----- cleaning up -----
Comment 3 Daniel Berrange 2008-08-22 09:31:34 EDT
Ah right, its Xenner - i forgot we had this tracked already

*** This bug has been marked as a duplicate of bug 454616 ***
Comment 4 Ahmed Medhat 2008-08-22 09:54:11 EDT
Fine, should I get the patch https://bugzilla.redhat.com/attachment.cgi?id=311382 and recompile the xenner source rpm after applying the patch ?
Comment 5 Ahmed Medhat 2008-08-22 10:32:11 EDT
Well, I did apply the patch (to libvirtd) and recompiled the rpms and still not working and returning the same error, I know I was not told to do so but thought trying won't hurt.
Comment 6 Ahmed Medhat 2008-08-26 14:54:55 EDT

It turns out that the Xenner services was not running by default in Fedora 9, applying /etc/init.d/xenner to start on booting fixed this issues so far besides applying the patch https://bugzilla.redhat.com/attachment.cgi?id=311382 .

Thanks, /Ahmed Medhat/

Note You need to log in before you can comment on or make changes to this bug.