Bug 459797 - mkinitrd does not include lvm_<host_tag>.conf
mkinitrd does not include lvm_<host_tag>.conf
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Brian Lane
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-22 09:41 EDT by Trond H. Amundsen
Modified: 2013-03-20 09:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-20 09:38:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trond H. Amundsen 2008-08-22 09:41:44 EDT
Description of problem:

When using LVM hosttags and a root partition under LVM, mkinitrd
should include any lvm_<host_tag>.conf files.


Version-Release number of selected component (if applicable):
mkinitrd-5.1.19.6-28

How reproducible:
Always

Steps to Reproduce:
1. Use an LV as the root partition
2. Add 'tags { hosttags = 1 }' to lvm.conf
3. Create a file /etc/lvm/lvm_$(uname -n).conf that contains
   'activation { volume_list=["@<hostname>"] }' where <hostname> equals
   the output from 'uname -n'.
4. Add a host tag to the VG containing the root partition with
   'vgchange --addtag $(uname -n) <vol_group>'
5. Create new initrd
6. Reboot


Actual results:
Machine panics. Can't mount root partition because the VG is never
activated.

Expected results:
Normal bootup.

Additional info:
A workaround exists: Don't use lvm_<host_tag>.conf. Put everything in
lvm.conf.
Comment 1 David Cantrell 2013-03-20 09:38:24 EDT
While Red Hat welcomes bug reports on Red Hat products here in our public
bugzilla database, please keep in mind that bugzilla is not a support tool or
means of accessing support.  If you would like technical support please visit
our support portal at access.redhat.com or call us for information on
subscription offerings to suit your needs.

Note You need to log in before you can comment on or make changes to this bug.