Bug 459852 - kmail won't start
kmail won't start
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
9
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-22 20:50 EDT by Dimitri Maziuk
Modified: 2008-08-25 17:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-25 12:24:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dimitri Maziuk 2008-08-22 20:50:30 EDT
Description of problem:
after yum-update ran on Aug 21 2008, kmail won't start

Version-Release number of selected component (if applicable):
kdepim-3.5.9-10.fc9.x86_64

How reproducible:
always

Steps to Reproduce:
1. start kmail
  
Actual results:

none.

Expected results:

KDE wallet dialog box should pop up.

Additional info:

tail of `strace kmail`

write(3, "\0\0\0\26/share/dmaziuk/passwd\0\0\0\0\1\0\0"..., 46) = 46
read(3, "\2\5\0\2\"\0\0\0", 8)          = 8
read(3, "\2\0\0\0", 4)                  = 4
read(3, "\0\0\0\6kmail\0\0\0\0\20anonymous-14984\0\0\0"..., 34) = 34
read(3, WeaverThreadLogger: thread (ID: 1) suspended.
WeaverThreadLogger: thread (ID: 2) suspended.
WeaverThreadLogger: thread (ID: 3) suspended.
WeaverThreadLogger: thread (ID: 4) suspended.

-- and it hangs here forever.
Comment 1 Rex Dieter 2008-08-25 10:29:46 EDT
I cannot reproduce.  

Is this box fully up-to-date (wrt stable updates)?
Does this happen for all users or one in particular?

If answers are yes, all, respectively, please forward this to upstream developers and report to bugs.kde.org (against kdepim).
Comment 2 Dimitri Maziuk 2008-08-25 12:18:08 EDT
Here's the fix:
1. delete ~/.ICEauthority
2. reboot (logging out and back in didn't work)
3. after logging in, start apcupsd widget -- somehow that makes kalarm and wallet start up.
4. kmail now works.

So far my experience with FC9/KDE4 is "do I take time to replace it with FC8 now, or do I replace it with kubuntu tomorrow". Great job with the distro.
Comment 3 Rex Dieter 2008-08-25 12:24:58 EDT
Glad you got it working.

sounds like more an issue of .ICEauthority corrupted and/or apcupsd interfering somehow.  We don't have much else to do on to debug this to be kde(4)'s fault.

If you've got more details or evidence, we'd be happy to help explore this further.
Comment 4 Kevin Kofler 2008-08-25 12:30:03 EDT
Did you attempt to run a KDE app under su or sudo? Because that's what usually causes problems like corrupt *authority files. (kdesu exists for a reason.)
Comment 5 Dimitri Maziuk 2008-08-25 12:45:05 EDT
> Did you attempt to run a KDE app under su or sudo? Because that's what usually
> causes problems like corrupt *authority files. (kdesu exists for a reason.)

I don't think so: I never run gui apps under sudo 'cause it never worked -- but I may have accidentally typed a wrong thing in a wrong shell. That could've been weeks ago, and the problem only surfaced after a logout.
Thanks for kdesu tip.
Comment 6 Dimitri Maziuk 2008-08-25 12:48:42 EDT
BTW, you do realize that there is no kdesu?
Comment 7 Kevin Kofler 2008-08-25 15:50:48 EDT
It's in /usr/libexec/kde4/kdesu. There's a /usr/bin/kdesu in kdebase3, but it doesn't work with KDE 4 apps for some reason.
Comment 8 Dimitri Maziuk 2008-08-25 16:49:21 EDT
(In reply to comment #7)
> It's in /usr/libexec/kde4/kdesu. There's a /usr/bin/kdesu in kdebase3, but it
> doesn't work with KDE 4 apps for some reason.

Yeah, exactly. See my earlier comment about the great job. Somehow "doesn't work for some reason" is a SOP for KDE4 apps in FC9 -- I'm yet to find anything that's actually done and/or works better than in KDE3/FC8.
Comment 9 Rex Dieter 2008-08-25 17:46:29 EDT
Then by all means, use F8/KDE3 if that makes you happy.  

Commenting on upstream development/design decisions here won't do anyone any good.

Note You need to log in before you can comment on or make changes to this bug.