Bug 459860 - net can't be up due to syntax error
net can't be up due to syntax error
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-22 23:41 EDT by Mamoru TASAKA
Modified: 2008-08-24 21:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-23 17:18:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2008-08-22 23:41:13 EDT
Description of problem:
Reboot hangs due to syntax error on /sbin/dhclient-script

Version-Release number of selected component (if applicable):
dhclient-4.0.0-20.fc10

How reproducible:
100%

Steps to Reproduce:
1. # ifup eth0
2.
3.
  
Actual results:

Script started on Sat 23 Aug 2008 11:06:22 AM JST
[root@localhost ~]# ifup eth0

Determining IP information for eth0.../sbin/dhclient-script: line 426: syntax error near unexpected token `}'
/sbin/dhclient-script: line 426: `}'
/sbin/dhclient-script: line 426: syntax error near unexpected token `}'
/sbin/dhclient-script: line 426: `}'
^C
[root@localhost ~]# exit

Script done on Sat 23 Aug 2008 11:06:41 AM JST

Expected results:
ifup succeeds
Comment 1 David Cantrell 2008-08-23 17:18:27 EDT
Thanks for the report.  Sorry about that.  Should be fixed up now in dhcp-4.0.0-21.fc10.  If not, please let me know.
Comment 2 Vallimar 2008-08-24 19:00:50 EDT
Hello, There are two other issues (at least for me)

In order of failure:

>> Line 218 is missing a bracket.
>> Line 186 is failing the numerical comparison.

Sorry for the lateness of the report.
Comment 3 David Cantrell 2008-08-24 21:33:31 EDT
(In reply to comment #2)
> Hello, There are two other issues (at least for me)
> 
> In order of failure:
> 
> >> Line 218 is missing a bracket.
> >> Line 186 is failing the numerical comparison.
> 
> Sorry for the lateness of the report.

Thanks for the report.  I've corrected those two issues in dhcp-4.0.0-22.fc10.

Note You need to log in before you can comment on or make changes to this bug.