Bug 459884 - BZ flag changes not reflecting in mails
BZ flag changes not reflecting in mails
Status: CLOSED NOTABUG
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.2
All Linux
high Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-23 13:23 EDT by Rakesh Pandit
Modified: 2013-06-23 22:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-22 11:08:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rakesh Pandit 2008-08-23 13:23:23 EDT
Description of problem:
Recently I have noticed that upon change to flags(at least with fedora-review and fedora-cvs which I noticed), there is no mention of it in mail notice sent to fedora-package-review or folks in cc list.

Steps to reproduce:
1. Change status of ticket
2. Commit
3. Check fedora package review archive for mail.
Comment 1 David Lawrence 2008-08-26 23:34:03 EDT
this should be fixed as of today. Please reopen if not the case.
Comment 2 Kevin Fenzi 2008-09-05 17:30:30 EDT
It doesn't seem to be fixed here... 

A number of people have set fedora-cvs flag to ? and I haven't gotten any emails about it. ;( 

Can you doublecheck the fix?
Comment 3 Rakesh Pandit 2008-09-29 08:58:18 EDT
@dkl

ping
Comment 4 Rakesh Pandit 2008-10-07 14:03:43 EDT
@dkl

ping?
Comment 5 David Lawrence 2008-10-07 14:19:01 EDT
There were some fixes in recent weeks with the flag code filtering 
flag changes improperly in bug emails. Can someone verify that this is still an issue with the code that is on the live Bugzilla currently?

Thanks
Dave
Comment 6 Kevin Fenzi 2008-10-07 14:29:55 EDT
This is still as issue as of this morning. 

I processed the current fedora bugs with fedora-cvs: ? and set them each to + as I processed them. I didn't get any email for the ones getting set to ? or any emails for any of them that I set to + either. 

Some example bugs from this morning: 
bug 465944
bug 465831
bug 465830

I can provide more (there were about 15 this morning).
Comment 7 David Lawrence 2008-10-07 14:37:59 EDT
(In reply to comment #6)
> This is still as issue as of this morning. 
> 
> I processed the current fedora bugs with fedora-cvs: ? and set them each to +
> as I processed them. I didn't get any email for the ones getting set to ? or
> any emails for any of them that I set to + either. 
> 
> Some example bugs from this morning: 
> bug 465944
> bug 465831
> bug 465830
> 
> I can provide more (there were about 15 this morning).

Well I have to ask, do you have your email preferences set to send yourself the email changes even if you are the one making the changes? The default is that you do no receive any email for changes you make. 

You should have someone make the flag changes for you on a bug that you are attached to or set your preferences to send yourself all changes.

https://bugzilla.redhat.com/userprefs.cgi?tab=email

Dave
Comment 8 Kevin Fenzi 2008-10-07 14:46:36 EDT
Agreed, I probibly wouldn't get my changes, which is fine. 

However, I have never gotten any emails for anyone setting fedora-cvs to ? since the bugzilla upgrade. This used to happy before the upgrade. ;)
Comment 9 David Lawrence 2008-10-07 17:38:46 EDT
Hmm, I created a test fedora bug:

https://bugzilla.redhat.com/show_bug.cgi?id=466031

I set my email preferences to send me email for changes I made. And then I set the fedora flags which properly showed up in the email I received.


David Lawrence <dkl@redhat.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
               Flag|                            |fedora-review+, fedora-cvs+


Also there are no special permissions needed to *view* the fedora flags so that shouldnt be blocking the display of those in the emails.

Dave
Comment 10 Kevin Fenzi 2008-10-08 12:12:16 EDT
In reply to comment #9: 

Yes, that should work fine.

When anyone sets the 'fedora-cvs' flag that submission should mail a notice to 
cvsadmin-members@fedoraproject.org so they can notice the request and process it. 

Looking at this bug tho, perhaps Rakesh is seeing something else as the description doesn't seem to match what I was thinking this was about. ;( 
Rakesh?

I can file a new bug on the issue I was thinking of...
Comment 11 Rakesh Pandit 2008-10-22 11:08:26 EDT
There is a confusion here. This issue seems to solved with a new feature. Now I see separate personal updates going when flags are changed.

@Kevin
In case you see some different issue, please file a new request.

CLOSED -> NOTABUG

Note You need to log in before you can comment on or make changes to this bug.