Bug 459959 - Mass branch request
Mass branch request
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mencal (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-25 04:58 EDT by Lubomir Rintel
Modified: 2008-09-23 04:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-23 04:34:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Lubomir Rintel 2008-08-25 04:58:03 EDT
Package change request
======================
New branches: EL-5
New branch owners: lkundrak, jwrdegoede
Packages: libgda, libgnomedb, mdbtools

In Fedora these packages are owned by Hans, who states:
Does not maintain EPEL packages, wants to comaintain

I'm pulling these in as dependencies of gnumeric.

Adding Hans to Cc, so that he can point out any known problems for the versions I plan to import (ignore the dist tag):

libgda-3.0.1-6.el5.src.rpm
libgnomedb-3.0.0-6.el5.src.rpm
mdbtools-0.6-0.4.cvs20051109.el5.src.rpm
Comment 1 Hans de Goede 2008-08-25 09:50:14 EDT
Hi,

I've got no objections against these hitting EPEL nor against using the mentioned versions. I do have a request though, if possible I would like someone (you?) to take over these packages completely from me. I only picked these up / packaged these because they are dependencies of gnumeric. As I no longer maintain gnumeric I would be happy to give these to someone else.

Maybe huzaifas (in the CC) who also maintains gnumeric in Fedora now, wants to pick these up / co-maintain them?

Also talking about gnumeric deps, after huzaifas picked up gnumeric he also packaged psiconv, which gnumeric can use to convert from certain spreadsheet formats. So far huzaifas has not done a gnumeric update adding psiconv support (?) . But I guess he will in the near future, so IMHO it would be a good idea todo psiconv for EPEL too.
Comment 2 Kevin Fenzi 2008-08-25 15:49:02 EDT
Can you guys reset the fedora-cvs flag when you are ready here?
Comment 3 Lubomir Rintel 2008-09-09 16:08:50 EDT
I have no intention to maintain non-EPEL branches, but am willing to co-maintain them (dealing with possible updates && bug reports), since I know you do not have much free time :)

I'd appreciate if Huzaifa stated if he's willing to help here.

So -- for now, Kevin, please just create the requested branches.
Comment 4 Huzaifa S. Sidhpurwala 2008-09-10 00:56:07 EDT
(In reply to comment #3)
> I have no intention to maintain non-EPEL branches, but am willing to
> co-maintain them (dealing with possible updates && bug reports), since I know
> you do not have much free time :)
> 
> I'd appreciate if Huzaifa stated if he's willing to help here.
> 
Hi Lubomir,
I have branched gnumeric for EL-5, but it seems to depend on libgnomedb, which is also now branched for EL-5.
Now libgnomedb depends on several other non EL-5 packages, and i dont know what they in turn depend on.
I dont think i will be able to put all of them in EPEL yet,
Lubomir, if you are interested in following this, please go ahead and add your self to EL-5 in packagedb for gnumeric and libgnomedb.
Thanks.


> So -- for now, Kevin, please just create the requested branches.
Comment 5 Jason Tibbitts 2008-09-10 19:52:11 EDT
I was going to take care of this, but it seems I'm too dense to figure out what you actually want here.  I can't just create branches without giving them an owner, and Hans doesn't seem to want to be an owner, so what's left?  Just lkundrak?
Comment 6 Lubomir Rintel 2008-09-15 13:05:48 EDT
Package change request
======================
New branches: EL-5
New branch owners: lkundrak
Packages: libgda, libgnomedb, mdbtools
Comment 7 Kevin Fenzi 2008-09-17 15:03:49 EDT
cvs done.
Comment 8 Kevin Fenzi 2008-09-17 15:15:27 EDT
note: libgnomedb was already branched/maintained in EL-5. 
Check with the owner there for maintainership.
Comment 9 Lubomir Rintel 2008-09-23 04:00:22 EDT
Imported and built thanks!

Note You need to log in before you can comment on or make changes to this bug.