This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 459981 - LC_TELEPHONE tel_dom_fmt localization
LC_TELEPHONE tel_dom_fmt localization
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: glibc (Show other bugs)
5.2
All Linux
medium Severity low
: rc
: ---
Assigned To: Andreas Schwab
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-25 10:00 EDT by Andrew C Aitchison
Modified: 2009-11-22 12:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-22 12:51:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew C Aitchison 2008-08-25 10:00:36 EDT
Description of problem:
in en_GB locales LC_TELEPHONE does not match local custom

Version-Release number of selected component (if applicable):
glibc-2.5-24

How reproducible:
Always

Steps to Reproduce:
1.LANG=en_GB
2.locale -ck LC_TELEPHONE
  
Actual results:
LC_TELEPHONE
tel_int_fmt="+%c %a %l"
tel_dom_fmt="%a %l"
int_select="00"
int_prefix="44"
telephone-codeset="ISO-8859-1"

Expected results:
...
tel_dom_fmt="%A %l"
...

since UK phone numbers are usually written
01223 337992 or +44 1223 337992
(domestic area codes have prefix 0, internationally they don't)

I believe that the same custom applies in France, Germany
and possibly other European countries, thus locales fr_FR* and de_DE*
need fixing too.

Additional info:
http://www.open-std.org/JTC1/SC22/WG20/docs/n972-14652ft.pdf
section 4.12 defines:
        %a area code without nationwide prefix (prefix is often <0>).
        %A area code including nationwide prefix (prefix is often <0>).
Comment 1 Ulrich Drepper 2008-09-16 01:12:26 EDT
I've changed upstream.  But I don't think this is a change which has to be in a RHEL update.
Comment 2 Ulrich Drepper 2009-11-22 12:51:15 EST
I'm closing this.  The change will be in RHEL6 but not backported to RHEL5.

Note You need to log in before you can comment on or make changes to this bug.