Bug 460062 - kernel header broken for fcntl.h
kernel header broken for fcntl.h
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-25 17:19 EDT by Steve Grubb
Modified: 2008-09-04 14:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-04 14:58:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test script (305 bytes, text/plain)
2008-08-26 10:15 EDT, Steve Grubb
no flags Details

  None (edit)
Description Steve Grubb 2008-08-25 17:19:36 EDT
Description of problem:
Programs that include net.h won't compile.


Version-Release number of selected component (if applicable):



How reproducible:
Always


Steps to Reproduce:
.Build this app on rawhide machine:
#include <linux/net.h>
int main(void)
{ return 0; }

  
Actual results:

In file included from /usr/include/asm/fcntl.h:1,
                 from /usr/include/linux/fcntl.h:4,
                 from /usr/include/linux/net.h:23,
                 from gen_tables.c:28:
/usr/include/asm-generic/fcntl.h:120: error: expected specifier-qualifier-list before 'off_t'
/usr/include/asm-generic/fcntl.h:143: error: expected specifier-qualifier-list before 'loff_t'

Expected results:
Program built

Additional info:
This is blocking builds in rawhide.
Comment 1 Steve Grubb 2008-08-25 17:21:03 EDT
version-release is: kernel-headers-0.244.rc2.git1.fc10
Comment 2 Dave Jones 2008-08-25 18:35:37 EDT
I don't have a working rawhide install right now, so I can't reproduce this locally, but..  -rc4 should be in the builders, so the last comment is confusing.

Can you grab that (directly from koji.fp.o until the rawhide pushes happen again) and retry?

It's possible that the bug is still there in -rc4, but I'd like confirmation before I start digging.
Comment 3 Steve Grubb 2008-08-26 08:55:11 EDT
From the audit package's root.log in koji:

DEBUG util.py:250:   kernel-headers          x86_64     2.6.27-0.275.rc4.git2.fc10  build             721 k

http://koji.fedoraproject.org/koji/getfile?taskID=785282&name=root.log
Comment 4 Steve Grubb 2008-08-26 10:15:42 EDT
Created attachment 315002 [details]
test script

The problems in the headers are in several files besides the one that is blocking build of the audit package. The attached script builds a noop program with each header in the /usr/include/linux directory in turn to see if it compiles. Not sure if this is a valid use of headers, but I assume that as long as I don't call bits, or asm headers directly, the linux headers are sane.
Comment 5 Steve Grubb 2008-08-26 10:33:09 EDT
http://www.ussg.iu.edu/hypermail/linux/kernel/0808.3/0732.html

dwmw2 sent the above patch to fix this.
Comment 6 Steve Grubb 2008-09-04 14:58:59 EDT
current rawhide allows audit package to build. Closing.

Note You need to log in before you can comment on or make changes to this bug.