Bug 460138 - libvirt-devel should require xen-devel
libvirt-devel should require xen-devel
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-26 09:11 EDT by Richard W.M. Jones
Modified: 2009-12-14 16:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:22:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2008-08-26 09:11:14 EDT
libvirt-devel requires an explicit dependency on xen-devel.

Because this is currently lacking, linking against libvirt fails, eg:
configure:36715: checking for virDomainBlockStats in -lvirt
configure:36750: gcc -o conftest -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables     -lvirt -lxenstore   conftest.c -lvirt   >&5
/usr/bin/ld: cannot find -lxenstore
collect2: ld returned 1 exit status

Note that this was fixed in Fedora about 2 years ago:
https://bugzilla.redhat.com/show_bug.cgi?id=202320#c2
Comment 2 Daniel Veillard 2008-08-27 04:37:08 EDT
libvirt-0.3.3-12.el5 has been built in dist-5E-qu-candidate with the fix


Daniel
Comment 6 errata-xmlrpc 2009-01-20 16:22:04 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0142.html

Note You need to log in before you can comment on or make changes to this bug.