Bug 460139 - PyOpenGL make the Python help prompt fail
PyOpenGL make the Python help prompt fail
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: PyOpenGL (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nikolay Vladimirov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-26 09:23 EDT by Michael Ughetto
Modified: 2008-10-07 05:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-07 05:48:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Ughetto 2008-08-26 09:23:50 EDT
Description of problem:
When typing "modules" into the python help interpreter the command fails.

Steps to Reproduce:
1. $python
2. >>> help()
3. help> modules
  
Actual results:

Please wait a moment while I gather a list of all available modules...

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.5/site.py", line 346, in __call__
    return pydoc.help(*args, **kwds)
  File "/usr/lib/python2.5/pydoc.py", line 1646, in __call__
    self.interact()
  File "/usr/lib/python2.5/pydoc.py", line 1664, in interact
    self.help(request)
  File "/usr/lib/python2.5/pydoc.py", line 1680, in help
    elif request == 'modules': self.listmodules()
  File "/usr/lib/python2.5/pydoc.py", line 1801, in listmodules
    ModuleScanner().run(callback)
  File "/usr/lib/python2.5/pydoc.py", line 1852, in run
    for importer, modname, ispkg in pkgutil.walk_packages():
  File "/usr/lib/python2.5/pkgutil.py", line 125, in walk_packages
    for item in walk_packages(path, name+'.', onerror):
  File "/usr/lib/python2.5/pkgutil.py", line 125, in walk_packages
    for item in walk_packages(path, name+'.', onerror):
  File "/usr/lib/python2.5/pkgutil.py", line 110, in walk_packages
    __import__(name)
  File "/usr/lib/python2.5/site-packages/OpenGL/WGL/__init__.py", line 3, in <module>
    wglUseFontBitmaps = wglUseFontBitmapsW
NameError: name 'wglUseFontBitmapsW' is not defined

Expected results:

modules should return a correct list of installed Python modules

Additional info:

The bug works on i386 and x86_64, removing the package make the error disappear.
Comment 1 Michael Ughetto 2008-09-19 12:24:48 EDT
Any news ?
Comment 2 Fedora Update System 2008-09-22 05:18:11 EDT
PyOpenGL-3.0.0-0.8.b6.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/PyOpenGL-3.0.0-0.8.b6.fc9
Comment 3 Nikolay Vladimirov 2008-09-22 05:21:51 EDT
Sorry for the delay, I was away for a while. The bug should be fixed in the new version.
Comment 4 Fedora Update System 2008-09-24 20:11:46 EDT
PyOpenGL-3.0.0-0.8.b6.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update PyOpenGL'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8248
Comment 5 Fedora Update System 2008-10-07 05:47:57 EDT
PyOpenGL-3.0.0-0.8.b6.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.