Bug 460149 - component-openmpi-libraries not present in repository
component-openmpi-libraries not present in repository
Status: CLOSED CURRENTRELEASE
Product: Red Hat HPC Solution
Classification: Red Hat
Component: kit-hpc (Show other bugs)
5.2
All Linux
medium Severity high
: ---
: ---
Assigned To: OCS Support
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-26 10:04 EDT by Rafael Garabato
Modified: 2008-09-22 15:34 EDT (History)
4 users (show)

See Also:
Fixed In Version: component-openmpi-libraries-0.1-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-22 15:34:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rafael Garabato 2008-08-26 10:04:29 EDT
Description of problem:
When adding the kit to the nodes with ngedit, it appears a compoment called component-openmpi-libraries. But this component is not present in the package repositories. The installation says it succeeded however.


After installing the kit with the /opt/kusu/sbin/install-kit-hpc

Version-Release number of selected component (if applicable):
Red Hat 5.2. kit-hpc-0.1-2

How reproducible: Always


Steps to Reproduce:
1. Download the hpc kit installer
2. Install the kit /opt/kusu/sbin/install-kit-hpc
3. Go to the folder /depot/kits/hpc/0.1/x86_64
4. Verify that the component is present in the kit
grep "component-openmpi" kitinfo
5. Check that the component is not present in the local repository
ls component-*

  
Actual results:
[root@hpchead x86_64]# pwd
/depot/kits/hpc/0.1/x86_64
[root@hpchead x86_64]# grep "component-openmpi" kitinfo
  'pkgname': 'component-openmpi-libraries',
[root@hpchead x86_64]# ls component-*
component-benchmarking-tools-0.1-3.noarch.rpm
component-hpc-libraries-0.1-2.noarch.rpm
component-mpich1-libraries-0.1-2.noarch.rpm
component-mpich2-libraries-0.1-2.noarch.rpm
component-mvapich1-libraries-0.1-2.noarch.rpm
component-mvapich2-libraries-0.1-2.noarch.rpm


Expected results:


Additional info:
The missing component is the yum repositories but was not installed 
[root@hpchead x86_64]# yum list | grep component
component-base-installer.noarch          5.1-4                  installed
component-benchmarking-tools.noarch      0.1-3                  installed
component-ganglia-server-v3_0.noarch     3.0-2                  installed
component-gnome-desktop.noarch           5.1-2                  installed
component-hpc-libraries.noarch           0.1-2                  installed
component-lava-compute-v1_0.noarch       1.0-3                  installed
component-lava-master-v1_0.noarch        1.0-3                  installed
component-mpich1-libraries.noarch        0.1-2                  installed
component-mpich2-libraries.noarch        0.1-2                  installed
component-mvapich1-libraries.noarch      0.1-2                  installed
component-mvapich2-libraries.noarch      0.1-2                  installed
component-ntop-v3_3.noarch               3.3-5                  installed
component-RHEL-OFED.noarch               1.2.5-2                kusu-installer-S
component-RHEL-OFED-devel.noarch         1.2.5-2                kusu-installer-S
component-base-node.noarch               5.1-2                  kusu-installer-S
component-cacti.noarch                   0.1-42                 rhel-x86_64-serv
component-cacti-monitored-node.noarch    0.1-38                 rhel-x86_64-serv
component-ganglia-agent-v3_0.noarch      3.0-1.1                kusu-installer-S
component-openmpi-libraries.noarch       0.1-2                  rhel-x86_64-serv

The problem is that the script:

/opt/kusu/sbin/install-kit-hpc

Does not download the component component-openmpi-libraries.
Comment 1 Mark Black 2008-09-02 09:07:45 EDT
Updated SRPMs have been provided to Red Hat.
Comment 2 Rafael Garabato 2008-09-03 09:13:35 EDT
Once the new packages are added to the Yum repository, Can anyone from Red Hat update the "Fixed in Version" field? Just to be sure I am using the right package version.
Comment 3 Nils Philippsen 2008-09-03 10:27:46 EDT
I'd like Platform to do this -- they're assigned to the bug and will check that the packages they submitted for building are available via FTP/RHN anyway.
Comment 4 Rafael Garabato 2008-09-09 16:12:40 EDT
I noticed that the packages for this version were updated. The component-openmpi-libraries was added but it is still not working because an other packages is still missing in the installation script.

[root@rhhpcml ~]# cat /opt/kusu/sbin/install-kit-hpc  | grep interco
[root@rhhpcml ~]# yum list | grep interco
openmpi-interconnects-gnu.x86_64         1.2.4-3                rhel-x86_64-serv
[root@rhhpcml ~]# yum list | grep hpc
component-hpc-libraries.noarch           0.1-2                  installed
kit-hpc.x86_64                           0.1-2                  installed
ocs-kit-hpc.noarch                       1.0-11                 installed


          â cfmsync reported successful return.                     â
          â                                                         â
          â Please inspect the output below:                        â
          â Error: Missing Dependency: openmpi-interconnects-gnu    â
          â is needed by package component-openmpi-libraries        â
          â Done                                                    â
          â Updating installer(s)                                   â
          â Sending to 10.0.0.255                                   â
          â Sending to 10.0.0.255                                   â
          â Sending to 10.0.0.255                                   â
          â Sending to 10.0.0.255                                   â
          â Sending to 10.0.0.255                                   â
          â                                                         â
Comment 5 Daniel Riek 2008-09-11 13:13:24 EDT
For all I can verify, this now works: not able to reproduce the errormessage anymore. Also the compute nodes can see the right packages:

[root@compute-17-01 ~]# yum list openmpi\*
Loading "rhnplugin" plugin
Loading "security" plugin
This system is not registered with RHN.
RHN support will be disabled.
Available Packages
openmpi.x86_64                           1.2.5-5.el5            kusu-compute-Ser
openmpi.i386                             1.2.5-5.el5            kusu-compute-Ser
openmpi-devel.i386                       1.2.5-5.el5            kusu-compute-Ser
openmpi-devel.x86_64                     1.2.5-5.el5            kusu-compute-Ser
openmpi-interconnects-gnu.x86_64         1.2.4-3                kusu-compute-Ser
openmpi-libs.x86_64                      1.2.5-5.el5            kusu-compute-Ser
openmpi-libs.i386                        1.2.5-5.el5            kusu-compute-Ser

Please re-open if you find another issue with this.
Comment 6 Rafael Garabato 2008-09-15 16:28:04 EDT
It is not installing correctly here:

Error: Missing Dependency: openmpi-interconnects-gnu is needed by         â
 â package component-openmpi-libraries                                       â
 â Done
Comment 7 Daniel Riek 2008-09-16 21:00:25 EDT
Can you please do a "yum -y upgrade" and then a "repopatch -r rhel5_x86_64" on the management node?
Comment 8 Daniel Riek 2008-09-16 21:06:46 EDT
Also, what is the output of "find /depot -iname \*interconn\*" ?
Comment 9 Rafael Garabato 2008-09-17 08:42:40 EDT
(In reply to comment #8)
> Also, what is the output of "find /depot -iname \*interconn\*" ?

Doesn't return anything:

[root@rhhpcx38ml ~]# find /depot -iname \*interconn\*
[root@rhhpcx38ml ~]#
Comment 10 Rafael Garabato 2008-09-17 08:44:44 EDT
(In reply to comment #7)
> Can you please do a "yum -y upgrade" and then a "repopatch -r rhel5_x86_64" on
> the management node?

Is this important because there are new packages of the Red Hat HPC channel?

I mean, how important is to do an update of the whole system before installing Red Hat HPC? (With yum -y upgrade)
Comment 11 Daniel Riek 2008-09-17 09:59:34 EDT
Depends on what you installed with. In general we recommend to do a full update before installing.

Did you start with 5.1 or 5.2?
Comment 12 Rafael Garabato 2008-09-17 10:08:14 EDT
I started with Red Hat 5.2.

Let me rephrase my question:
Will be a complete Red Hat Update, a mandatory requirement before installing Red Hat HPC? This would mean that without this Update, Red Hat HPC will not install.
Comment 13 OCS Support 2008-09-17 10:12:48 EDT
Upgrading the base OS is not strictly required, but is recommended.  yum should pull in upgraded packages as necessary.
Comment 14 Rafael Garabato 2008-09-17 11:16:13 EDT
Hi,

      "repopatch -r rhel5_x86_64" is faling, probably because I don't have the Proxy settings configured correctly. However, YUM is working correctly. I have set the environment variables http_proxy and ftp_proxy, is this OK?

Mi Kusu updates.conf file has the following lines:

[rhel]
username=<hidden>
password=<hidden>
url=https://xmlrpc.rhn.redhat.com/XMLRPC
yumrhn=https://rhn.redhat.com/rpc/api
Comment 15 OCS Support 2008-09-17 16:47:12 EDT
The repopatch may be logged in 461781.

The channel now has the right component version.

# rpm -qp --requires component-openmpi-libraries-0.1-5.noarch.rpm
openmpi             <-------  Changed bit
openmpi-devel
hdf5-openmpi-gnu
linpack-openmpi-gnu
blacs-openmpi-gnu
scalapack-openmpi-gnu
/bin/sh
/bin/sh
/bin/sh
/bin/sh
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
Comment 16 Daniel Riek 2008-09-22 15:34:08 EDT
Closing based on comment 15

Note You need to log in before you can comment on or make changes to this bug.