Bug 460185 - with protectio enabled, java client can deadlock (RHEL4)
with protectio enabled, java client can deadlock (RHEL4)
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-java (Show other bugs)
1.0
All Linux
urgent Severity high
: 1.0.1
: ---
Assigned To: messaging-bugs
Kim van der Riet
:
Depends On: 455247
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-26 13:05 EDT by Rafael H. Schloming
Modified: 2014-12-01 18:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-06 14:59:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rafael H. Schloming 2008-08-26 13:05:46 EDT
+++ This bug was initially created as a clone of Bug #455247 +++

With -Dprotectio=true, the java client adds a MINA filter that will block writes
if there are more than N bytes of outstanding writes being held in memory.
Unfortunately, this can cause deadlocks in the client because MINA only uses one
thread to process all I/O (both reads and writes). The deadlock can occur when
the client tries to write directly from the callback made by the MINA I/O
thread. If this write attempt should block, then MINAs I/O thread will block
until some outstanding writes have been made, but no more writes can ever be
made because the MINA I/O thread that is supposed to do those writes is being
blocked by the callback.
Comment 4 errata-xmlrpc 2008-10-06 14:59:37 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0867.html

Note You need to log in before you can comment on or make changes to this bug.