Bug 460189 - block layer tagging needs several bug fixes from upstream
block layer tagging needs several bug fixes from upstream
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Mike Christie
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-26 13:36 EDT by Mike Christie
Modified: 2008-10-21 16:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-21 16:40:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Christie 2008-08-26 13:36:53 EDT
Description of problem:

1. When block layer tagging is used by scsi-ml for host wide tagging we do not access the bqt counter under a lock so it is racey and can incorrectly report errors.
2. LLDs are setting the device queue depth to the host wide queue depth.
3. scsi-ml can queue a command with an invalid tag.

These are fixed upstream (#1 is being merged now).


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 RHEL Product and Program Management 2008-08-26 13:43:05 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 3 RHEL Product and Program Management 2008-08-26 14:02:57 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 4 RHEL Product and Program Management 2008-08-26 14:44:06 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Tom Coughlan 2008-10-20 17:48:18 EDT
Defer to 5.4, due to lack of resources.
Comment 6 Mike Christie 2008-10-21 16:40:39 EDT
I closing this because I thought we could port all the host based tag mapping for fcoe. It turns out all the drivers in RHEL5 did their own mapping, so the port was more invassive than I wanted to risk for just fcoe.

Note You need to log in before you can comment on or make changes to this bug.