Bug 460213 - CDT Test Failures/Errors
CDT Test Failures/Errors
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse-cdt (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnston
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-26 16:11 EDT by Elliott Baron
Modified: 2009-02-13 15:49 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-13 15:49:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elliott Baron 2008-08-26 16:11:04 EDT
My results from Headless Test

#Tests: 4431
#Failures: 43
#Errors: 23

Failures
---------
org.eclipse.cdt.debug.core.tests.DebugTests.testDebug
org.eclipse.cdt.debug.core.tests.BreakpointTests.testCondBreak

org.eclipse.cdt.managedbuilder.core.tests.ManagedProjectUpdateTests.testProjectUpdate12_Update
org.eclipse.cdt.managedbuilder.core.tests.ManagedProjectUpdateTests.testProjectUpdate21_Update
org.eclipse.cdt.managedbuilder.core.tests.ManagedProjectUpdateTests.testProjectUpdate21CPP_Update
org.eclipse.cdt.managedbuilder.core.tests.ManagedProject21MakefileTests.testSingleFileExe
org.eclipse.cdt.managedbuilder.core.tests.ManagedProject21MakefileTests.testTwoFileSO
org.eclipse.cdt.managedbuilder.core.tests.ManagedProject21MakefileTests.testMultiResConfig
org.eclipse.cdt.managedbuilder.core.tests.ManagedProject21MakefileTests.testLinkedLib
org.eclipse.cdt.managedbuilder.core.tests.ManagedProject30MakefileTests.test30SingleFileExe
org.eclipse.cdt.managedbuilder.core.tests.ManagedProject30MakefileTests.test30TwoFileSO
org.eclipse.cdt.managedbuilder.core.tests.ManagedProject30MakefileTests.test30MultiResConfig
org.eclipse.cdt.managedbuilder.core.tests.ManagedProject30MakefileTests.test30LinkedLib
org.eclipse.cdt.managedbuilder.core.tests.ManagedProject30MakefileTests.test30CopyandDeploy
org.eclipse.cdt.managedbuilder.core.tests.ManagedProject30MakefileTests.test30DeleteFile
org.eclipse.cdt.managedbuilder.core.tests.ManagedProject30MakefileTests.testFileWithNoExtension
org.eclipse.cdt.managedbuilder.core.tests.ManagedProject30MakefileTests.testPreAndPostProcessBuildSteps
org.eclipse.cdt.managedbuilder.core.tests.ManagedProject30MakefileTests.testResourceCustomBuildStep
org.eclipse.cdt.managedbuilder.core.tests.ManagedProject30MakefileTests.test30_1
org.eclipse.cdt.managedbuilder.core.tests.ManagedProject30MakefileTests.test30_2
org.eclipse.cdt.managedbuilder.core.tests.ManagedProject30MakefileTests.CDTFortranTest1
org.eclipse.cdt.managedbuilder.core.tests.ManagedProject30MakefileTests.CDTFortranTest2
org.eclipse.cdt.managedbuilder.core.tests.ManagedProject30MakefileTests.TestATO
org.eclipse.cdt.managedbuilder.core.tests.ManagedProject30MakefileTests.testMacroSupportInBuildDefinitions
org.eclipse.cdt.managedbuilder.core.tests.ManagedProject30MakefileTests.testSpaces
org.eclipse.cdt.managedbuilder.core.tests.ManagedBuildMacrosTests.testMacroOptL
org.eclipse.cdt.managedbuilder.core.tests.ManagedBuildDependencyCalculatorTests.test1DepCalc2
org.eclipse.cdt.managedbuilder.core.tests.ManagedBuildDependencyCalculatorTests.test1DepCalc3
org.eclipse.cdt.managedbuilder.core.tests.ManagedBuildDependencyCalculatorTests.test1DepCalcPreBuild

org.eclipse.cdt.ui.tests.refactoring.rename.RenameRegressionTests.testFunction_31
org.eclipse.cdt.ui.tests.refactoring.rename.RenameRegressionTests.testClass_53
org.eclipse.cdt.ui.tests.refactoring.rename.RenameRegressionTests.testClass_55_72748
org.eclipse.cdt.ui.tests.refactoring.rename.RenameRegressionTests.testClass_56
org.eclipse.cdt.ui.tests.refactoring.rename.RenameRegressionTests.testAttribute_64
org.eclipse.cdt.ui.tests.refactoring.rename.RenameRegressionTests.testNamespace_66
org.eclipse.cdt.ui.tests.refactoring.rename.RenameRegressionTests.testNamespace_66_79282
org.eclipse.cdt.ui.tests.refactoring.rename.RenameRegressionTests.testFunction_67
org.eclipse.cdt.ui.tests.refactoring.rename.RenameRegressionTests.testVariable_68
org.eclipse.cdt.ui.tests.refactoring.rename.RenameRegressionTests.testVariable_68_79295
org.eclipse.cdt.ui.tests.refactoring.rename.RenameRegressionTests.testVariable_88_72617
org.eclipse.cdt.ui.tests.refactoring.rename.RenameRegressionTests.testRenameParticipant
org.eclipse.cdt.ui.tests.refactoring.rename.RenameVariableTests.testBug72646
org.eclipse.cdt.ui.tests.refactoring.rename.RenameMacroTests.testMacroParameters


Errors
---------
org.eclipse.cdt.core.model.tests.CModelTests.testFileType
org.eclipse.cdt.core.model.tests.ArchiveTests.testGetBinaries
org.eclipse.cdt.core.model.tests.ArchiveTests.testIsArchive
org.eclipse.cdt.core.model.tests.TranslationUnitTests.testIsTranslationUnit
org.eclipse.cdt.core.model.tests.TranslationUnitTests.testGetChildren
org.eclipse.cdt.core.model.tests.TranslationUnitTests.testGetElement
org.eclipse.cdt.core.model.tests.TranslationUnitTests.testBug23478A
org.eclipse.cdt.core.model.tests.TranslationUnitTests.testBug23478B
org.eclipse.cdt.core.model.tests.TranslationUnitTests.testIsValidSourceUnitName
org.eclipse.cdt.core.model.tests.TranslationUnitTests.testAssemblyContentType_Bug186774
org.eclipse.cdt.core.model.tests.BinaryTests.testGetChildren
org.eclipse.cdt.core.model.tests.BinaryTests.testGetBss
org.eclipse.cdt.core.model.tests.BinaryTests.testGetData
org.eclipse.cdt.core.model.tests.BinaryTests.testGetCpu
org.eclipse.cdt.core.model.tests.BinaryTests.testGetNeededSharedLibs
org.eclipse.cdt.core.model.tests.BinaryTests.testGetSoname
org.eclipse.cdt.core.model.tests.BinaryTests.testGetText
org.eclipse.cdt.core.model.tests.BinaryTests.testHasDebug
org.eclipse.cdt.core.model.tests.BinaryTests.testisBinRead
org.eclipse.cdt.core.model.tests.BinaryTests.testIsObject
org.eclipse.cdt.core.model.tests.BinaryTests.testIsSharedLib
org.eclipse.cdt.core.model.tests.BinaryTests.testIsExecutable
org.eclipse.cdt.core.model.tests.BinaryTests.testIsBinary
Comment 1 Kent Sebastian 2008-08-26 16:45:57 EDT
My results:

Tests: 4431
Failures: 46
Errors: 23

Failures (diff)
---------------
-org.eclipse.cdt.debug.core.tests.DebugTests.testDebug

+org.eclipse.cdt.managedbuilder.core.tests.BuildDescriptionModelTests.testDes_gnu30_exe_deps
+org.eclipse.cdt.managedbuilder.core.tests.BuildDescriptionModelTests.testDesRebuildStateInDescription
+org.eclipse.cdt.managedbuilder.core.tests.ManagedBuildCoreTests20.testConfigurationReset
+org.eclipse.cdt.managedbuilder.core.tests.ManagedBuildCoreTests20.testConfigurations


Errors (diff)
-------------

(same as yours)
Comment 2 Andrew Overholt 2008-08-26 17:19:14 EDT
(In reply to comment #0)
> Errors

All 23 of these errors are due to the fact that we remove all .sos as part of %prep.  I've written a Makefile to re-build the test .sos (and .a files) and will add it to the build.  If I run the tests with the .sos around, I get 0 errors.

As for me, I'm getting 4 errors more than what upstream gets:

* testToolChainConversion_CDT21         
* testProjectConversion                 
* test1DepCalc2                         
* test1DepCalc3                         
* test1DepCalcPreBuild

I'm tracking these down now.
Comment 3 Elliott Baron 2008-08-27 09:54:49 EDT
From workspace

All org.eclipse.cdt.debug.core.tests and org.eclipse.cdt.ui.tests pass

Leaving only the managedbuilder tests failing, which I get the same results as above for.
Comment 4 Bug Zapper 2008-11-25 21:51:41 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Andrew Overholt 2009-02-13 15:49:41 EST
There are better places for us to track this.  I'll close this.

Note You need to log in before you can comment on or make changes to this bug.