Bug 460232 - syslog creates files with mode 0600
syslog creates files with mode 0600
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sysklogd (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Peter Vrabec
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-26 17:30 EDT by Jeff Bastian
Modified: 2010-03-30 04:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 04:15:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Bastian 2008-08-26 17:30:39 EDT
+++ This bug was initially created as a clone of Bug #460228 +++

RHEL5 syslogd creates files with mode 0600 due to umask 077 in the
init script.  This contradicts the manual page (and confuses
users) since it says: "If a file is created it is world readable."

Please update the man page to reflect this behavior.

Suggestion for modification for sysklogd(8) man page:

BUGS
       If an error occurs in one line the whole rule is ignored.

       Syslogd  doesn’t change the filemode of opened logfiles at any stage of
       process.  If a file is created it is world readable, however, the syslog
       init script in Red Hat Enterprise Linux sets umask to 077 so only root
       has read permissions.  You can also change the permissions on your own.
       This could be done in combination  with  rotating  logfiles  using  the
       ...
Comment 1 RHEL Product and Program Management 2009-03-26 13:13:55 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 6 errata-xmlrpc 2010-03-30 04:15:31 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0211.html

Note You need to log in before you can comment on or make changes to this bug.