Bug 460249 - mailx installing to wrong location breaks redhat-lsb - Cannot not install due to wrong location of mailx binary
mailx installing to wrong location breaks redhat-lsb - Cannot not install due...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-lsb (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hao Liu
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-26 22:15 EDT by Shawn Starr
Modified: 2008-10-11 11:22 EDT (History)
2 users (show)

See Also:
Fixed In Version: redhat-lsb3.2-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-11 11:22:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shawn Starr 2008-08-26 22:15:17 EDT
Description of problem: 
redhat-lsb cannot not install due to wrong location of mailx binary

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. yum install redhat-lsb from (koji static repo)
2. observe error

Actual results:

redhat-lsb-3.2-1.fc10.x86_64 from rawhide-x86_64 has depsolving problems
  --> Missing Dependency: /usr/bin/mailx is needed by package redhat-lsb-3.2-1.fc10.x86_64 (rawhide-x86_64)
Error: Missing Dependency: /usr/bin/mailx is needed by package redhat-lsb-3.2-1.fc10.x86_64 (rawhide-x86_64)

Expected results:

Package should install cleanly

Additional info:

I note on a debian system mailx is in /usr/bin (a symlink to mail actually which is in /usr/bin)
Comment 1 Dmitry Butskoy 2008-08-27 07:21:35 EDT
The issue is inspired by the latest update from redhat-lsb-3.1 to redhat-lsb-3.2

Previously, redhat-lsb required "/bin/mailx", but not it requires "/usr/bin/mailx" .

Please, change /usr/bin/mailx requiirement either to /biin/mailx or just to "mailx" (as a package name). Certainly if it is not conflict with LSB, if any...
Comment 2 Dmitry Butskoy 2008-08-27 07:23:20 EDT
..and sorry for my keyboard... iiiiiiii :)
Comment 3 Hao Liu 2008-08-27 22:03:35 EDT
Dmitry, 
  Yep, /bin/mailx is just a symlink to /bin/mail, we remove the symlink according to the bug: https://bugzilla.redhat.com/show_bug.cgi?id=457241, because F10 has its own mailx component, and it's installed under /usr/bin/.
  
  Would you please provide the following info?
  1. #which mailx
  2. #rpm -q mailx

  If there's no mailx but a symlink on your distribution, I think you need to install mailx through yum, after that, reinstall redhat-lsb, the error message should go.

  Thank you.
Comment 4 Hao Liu 2008-08-28 02:28:16 EDT
Fixed in redhat-lsb3.2-2
Comment 5 Shawn Starr 2008-10-11 11:22:09 EDT
Not any issue anymore. Closing

Note You need to log in before you can comment on or make changes to this bug.