Bug 460269 - system-config-samba can't handle valid smb.conf option variants without spaces
system-config-samba can't handle valid smb.conf option variants without spaces
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-samba (Show other bugs)
5.2
All Linux
medium Severity low
: rc
: ---
Assigned To: Nils Philippsen
qe-baseos-daemons
: Rebase
Depends On: 460272
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-27 04:27 EDT by Ales Zelinka
Modified: 2013-04-15 06:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-15 05:43:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ales Zelinka 2008-08-27 04:27:44 EDT
Description of problem:
Samba ignores whitespace in its configuration parameters, treating "read only" the same as "readonly". But system-config-samba doesn't recognize the options without whitespace, ending with traceback.


Version-Release number of selected component (if applicable):
system-config-samba-1.2.41-3

How reproducible:
always

Steps to Reproduce:
1. remove whitespace from any smb.conf option name (i.e. "guest ok" ->"guestok")
2. check with testparm that samba is still happy with the altered option
3. run system-config-samba
  
Actual results:
traceback with AttributeError: ('guestok', 'yes') at the end

Expected results:
working system-config-samba

Additional info:
Recognizing "compacted" options is a documented feature of samba. See file format section of smb.conf manual page.
Comment 1 Nils Philippsen 2008-08-27 05:20:11 EDT
Cloned this for Rawhide at bug #460272.
Comment 7 RHEL Product and Program Management 2009-11-06 14:15:14 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 9 RHEL Product and Program Management 2010-08-09 15:31:01 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 10 Nils Philippsen 2013-04-15 05:43:04 EDT
Unfortunately it's too late in the life cycle of Red Hat Enterprise Linux 5 to fix this bug. The upcoming 5.10 update is going to be the first production phase 2 release of Red Hat Enterprise Linux 5. From phase 2 on we'll be addressing primarily security and critical issues, therefore I'll close this bug. This issue is fixed in Red Hat Enterprise Linux version 6.
Comment 11 Nils Philippsen 2013-04-15 06:01:59 EDT
Correction: This is fixed in Fedora, the system-config-samba component isn't contained in Red Hat Enterprise Linux version 6 or later.

Note You need to log in before you can comment on or make changes to this bug.