Bug 460285 - evdev.c(EVIOCGBIT): Suspicious buffer size 511
evdev.c(EVIOCGBIT): Suspicious buffer size 511
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-27 07:50 EDT by Zdenek Kabelac
Modified: 2008-09-15 01:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-15 01:55:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zdenek Kabelac 2008-08-27 07:50:40 EDT
Description of problem:

My kernel doesn't like buffer size of synaptics driver I guess:

evdev.c(EVIOCGBIT): Suspicious buffer size 511, limiting output to 64 bytes. See http://userweb.kernel.org/~dtor/eviocgbit-bug.html

Version-Release number of selected component (if applicable):
synaptics-0.14.6-10.fc10.x86_64

How reproducible:
boot 2.6.27-rc kernel

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
updated driver according to given html page

Additional info:
Comment 1 Zdenek Kabelac 2008-09-03 09:08:01 EDT
It looks like the problem is no longer visible with package:

xorg-x11-drv-synaptics-0.15.0-3.fc10.x86_64

I guess this bug might be closed
Comment 2 Peter Hutterer 2008-09-15 01:55:05 EDT
Fixed with the following commit, and part of xorg-x11-drv-synaptics-0.15.0-1 and later.

commit 89b1add387b52ef55f5a8f87603153d27207e2f6
Author: Dmitry Torokhov <dmitry.torokhov@gmail.com>
Date:   Fri Aug 1 22:58:14 2008 +0200

    Fix crash on kernels with extended keymap space

Note You need to log in before you can comment on or make changes to this bug.