Bug 460298 - system-config-samba doesn't want to add user when unix-windows username mapping exists
system-config-samba doesn't want to add user when unix-windows username mappi...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-samba (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Nils Philippsen
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-27 09:18 EDT by Ales Zelinka
Modified: 2013-04-15 05:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-15 05:59:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Zelinka 2008-08-27 09:18:35 EDT
Description of problem:
system-config-samba  performs check whether user being added already exists in the samba database or not. But it doesn't check it against the list of real samba users, instead it checks it against the list of users who have unix-windows username mapping. These two lists are usually different.


Version-Release number of selected component (if applicable):
system-config-samba-1.2.41-3

How reproducible:
always

Steps to Reproduce:
1. add user to samba, don't create username mapping  (smbpasswd -a no-mapping)
2. add mapping for a user but don't add the actual user to samba (echo "mapped-user = alias" >> /username/mapping/file ; # the mapping file is /etc/samba/smbusers unless the "username map" option is used in smb.conf )
3. add no-mapping and mapped-user users via system-config-samba
  
Actual results:
- mapped-user is not allowed to be added even though he doesn't exist in the samba user database 
- no-mapping user is "re"added - overwriting previous record 

Expected results:
mapped-user added
no-mapping user not added


Additional info:
system-config-samba behaves like this only when checking usernames while adding. It correctly lists all existing samba users when configuring shares or in the "samba users" window.
Comment 1 Nils Philippsen 2008-08-27 11:24:30 EDT
Cloned for Rawhide as bug #460324.
Comment 3 RHEL Product and Program Management 2009-11-06 14:15:09 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 5 RHEL Product and Program Management 2010-08-09 15:30:53 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 6 Nils Philippsen 2013-04-15 05:59:45 EDT
Unfortunately it's too late in the life cycle of Red Hat Enterprise Linux 5 to fix this bug. The upcoming 5.10 update is going to be the first production phase 2 release of Red Hat Enterprise Linux 5. From phase 2 on we'll be addressing primarily security and critical issues, therefore I'll close this bug.

Note You need to log in before you can comment on or make changes to this bug.