Bug 460380 - mislabeled lib file
mislabeled lib file
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-27 16:53 EDT by Dominick Grift
Modified: 2008-08-29 15:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-29 15:54:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominick Grift 2008-08-27 16:53:42 EDT
Description of problem:
lib file in /usr mislabeled.
This was reported on irc

host=localhost.localdomain type=AVC msg=audit(1219865489.731:22): avc:  denied  { execute } for  pid=5232 comm="hpijs" path="/usr/share/hplip/prnt/plugins/lj-x86_32.so" dev=sda5 ino=1457107 scontext=system_u:system_r:hplip_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:usr_t:s0 tclass=file

host=localhost.localdomain type=SYSCALL msg=audit(1219865489.731:22): arch=40000003 syscall=192 success=no exit=-13 a0=0 a1=cea0 a2=5 a3=802 items=0 ppid=5225 pid=5232 auid=4294967295 uid=4 gid=7 euid=4 suid=4 fsuid=4 egid=7 sgid=7 fsgid=7 tty=(none) ses=4294967295 comm="hpijs" exe="/usr/bin/hpijs" subj=system_u:system_r:hplip_t:s0-s0:c0.c1023 key=(null)

chcon -t lib_t /usr/share/hplip/prnt/plugins/lj-x86_32.so

Version-Release number of selected component (if applicable):
f9
Comment 1 Daniel Walsh 2008-08-29 15:54:02 EDT
Well these are labeled correctly you just needed to run restorecon.  The problem is they installed a non rpm package and it did not label files correctly.

Note You need to log in before you can comment on or make changes to this bug.