Bug 460534 - Anaconda should only offer Update if RH is prepared to support it.
Anaconda should only offer Update if RH is prepared to support it.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: 5.4
Assigned To: Anaconda Maintenance Team
: FutureFeature
Depends On:
Blocks: 450884 483784
  Show dependency treegraph
 
Reported: 2008-08-28 09:34 EDT by George Beshers
Modified: 2009-04-13 16:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 16:38:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Beshers 2008-08-28 09:34:38 EDT
http://bugworks.engr.sgi.com/query.cgi/985052

1. Feature Name:  Anaconda Update Bug


2. Description:
   a. Architectures  mark all that apply 
        32-bit x86
      * 64-bit Itanium2
      * 64-bit AMD64/Intel EM64T
        64-bit IBM POWER
        31-bit IBM S/390
        64-bit IBM zSeries

   b. Dependencies:  broken anaconda

   c. External links:

   d. Priority  H,M,L : M -- I'm tired of getting bugs about it.

   e. Target Releases:  RHEL 5.4 or other release

   f. Target Release Date:

   g. Drivers or hardware dependency:  None

   h. Target Kernel:
  
3. Business Justification:   
   a. Why is this feature needed?
      It is confusing for anaconda to have an update option
      which is broken and RedHat doesn't support.
      In some circles it is called a "bug".

   b. What hardware does this enable?

   c. Forecast, volume or high end platform?
      All RedHat installs.

   d. Any configuration info?
      Offer the option only when RedHat is prepared to support it.

   e. When needed?  Release 5.0 would be ideal ;-)

   f. Are there other dependencies  drivers .

4. Status:
   a. Is code accepted upstream? If so, what version or patch?      
   No, this is an RH product.

5. Hardware to Red Hat? Red Hat can t integrate/test features without hardware.
   There is no hardware requirement.

6. Partner management contact, email, phone, chat

   John Hesterberg, jh@sgi.com, 651-683-5879, N/A

7. Partner technical contact, email, phone, chat

   George Beshers, gbeshers@sgi.com, 978-392-2447, N/A

   Where/LOCATION:  Westford, MA
Comment 1 Chris Lumens 2008-08-28 13:37:30 EDT
What exactly is being asked for here?  I can't see the referenced bug at the very beginning, as I assume it's on an internal server that I do not have access to.
Comment 2 George Beshers 2008-08-28 14:27:03 EDT
Sorry Chris.  There is some history here.

As part of SGI's normal QA we have been systematically
attempting to use Anaconda for updates; that is, load
a DVD on a system with an older OS, reboot, and ask for
the update rather than the fresh install.

Bugs have occurred.  This particular one is when the
disk has 15 partitions.  When the bugs were filed we
got the response that anaconda's update feature was
unsupported: first, for RHEL4 to RHEL5 and then
minor releases (I believe 4.6-4.7 and all minor releases
for rhel5).

This is a request that RH either decide when it will
support the anaconda upgrade and if it is NOT going
to support it, then please don't make it available.
As it stands it looks like RH is shipping a buggy
installer.

It has happened twice now that when I tell people
that I am onsite at RedHat (they usually don't
hear the SGI) they have ask why the installation
is busted --- but then it turns out they mean
the upgrade :-/.
Comment 4 Marizol Martinez 2008-12-15 14:38:43 EST
George -- Remember that upgrades between mayor releases (ie, RHEL 4 to RHEL 5) are not supported, only upgrades between minor releases (ie, RHEL 5.2 to RHEL 5.3) are.

If you have a found a valid bug while doing an upgrade from one minor release to another, please file it in the appropriate component. Or you can use IT if you want to involve GSS.

In your comment below, you mention a bug that occurs during partitioning. I recommend you close this BZ (so the the history doesn't confuse things), and report a new issue/bug for that partitioning problem.
Comment 6 Marizol Martinez 2009-04-13 16:38:28 EDT
Closing based on comment #4.

Note You need to log in before you can comment on or make changes to this bug.