Bug 460546 - pulse not support monitor link on bond interface
pulse not support monitor link on bond interface
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: piranha (Show other bugs)
4
All Linux
low Severity medium
: ---
: ---
Assigned To: Marek Grac
Cluster QE
:
Depends On: 457567
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-28 10:52 EDT by Marek Grac
Modified: 2009-05-18 17:19 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 17:19:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Grac 2008-08-28 10:52:28 EDT
+++ This bug was initially created as a clone of Bug #457567 +++

Description of problem:
With monitor_links enabled if the interface to monitor are bond interfaces the
monitor not work.

Version-Release number of selected component (if applicable):
The version of piranha used is piranha-0.8.4-9.3.el5

How reproducible:
- Create a bond interface on all server of cluster
- Create a cluster LVS with piranha and use a bond interface for public
- Pulse active on master server
- Pull out all cables of public interfaces on master server
  
Actual results:
Pulse not switch on slave node because is not monitor bond interface

Expected results:
Pulse switch on slave node

Additional info:
I attach the patch for resolve the problem.
pulse for monitor interface use SIOCETHTOOL but SIOCETHTOOL is not supported by
bond interface. I used SIOCGMIIREG when SIOCETHTOOL is not supported.

--- Additional comment from e.tano@palazzochigi.it on 2008-08-01 10:56:57 EDT ---

Created an attachment (id=313206)
Patch to resolve problem


--- Additional comment from e.tano@palazzochigi.it on 2008-08-01 10:58:15 EDT ---

I open also a "service request" on redhat
Comment 2 Marek Grac 2008-08-28 11:41:10 EDT
Patch added to CVS
Comment 3 Marek Grac 2008-09-03 08:49:57 EDT
New patch from RHEL-5 replaced the old one. There was few style problems (eh. copying definiton from net-tools version instead of system one)
Comment 6 errata-xmlrpc 2009-05-18 17:19:20 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1054.html

Note You need to log in before you can comment on or make changes to this bug.