Bug 460555 - upgrade to sendmail 8.14?
upgrade to sendmail 8.14?
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sendmail (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jaroslav Škarvada
: FutureFeature, Rebase, Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-28 11:55 EDT by James Ralston
Modified: 2010-10-23 00:08 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-10 03:47:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Ralston 2008-08-28 11:55:39 EDT
The latest RHEL5 release, 5.2, ships with sendmail 8.13.8 (the latest 8.13 sendmail release).

However, sendmail 8.14 has been available since 2007-01-31. (The latest 8.14 sendmail release is 8.14.3, released on 2008-05-03.)

Sendmail 8.14 has many desirable enhancements over sendmail 8.13.  In particular, the libmilter interface has been significantly extended, and several of the new libmilter features (e.g., the ability to change the envelope sender address) are features we very much want.

To my knowledge, any sendmail.mc files written for sendmail 8.13 should be forwards-compatible with sendmail 8.14. Furthermore, since Red Hat ships sendmail with only static versions of libmilter, libsm, and libsmutil, there is no possibility of breaking applications linked against sendmail 8.13 libraries.

RHEL5 is still in the "Production 1" phase, which includes selected software enhancements. I think upgrading to sendmail 8.14 would be a worthwhile enhancement. Please consider it.

Thanks.
Comment 1 James Ralston 2008-08-28 11:56:53 EDT
I've opened an enhancement request (Request Number 1853918) with Red Hat support as well.
Comment 7 RHEL Product and Program Management 2009-10-29 04:08:08 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.
Comment 8 James Ralston 2009-10-29 13:15:12 EDT
Briefly: why?

If the reason Development Management declined this request because they viewed other enhancement requests as having higher priority, that's fine.

But if Development Management declined the request because they know (or suspect) upgrading to sendmail 8.14 will break things, then I want to know that, because we are highly inclined to spin our own 8.14 RPMs for RHEL5, and would appreciate foreknowledge of any potential landmines...
Comment 9 R P Herrold 2009-10-29 13:34:52 EDT
ralston

It seems to be in Raw Hide ... it would seem that perhaps the Fedora process may hold the answer as to compatibility issues, as well as the sendmail upstream, of course.

[herrold@centos-5 ~]$ srcfind -r sendmail
/home/herrold/.tmp/srcfind.cache.txt
sendmail         /mnt/nfs/var/ftp/pub/mirror/redhat/rawhide/SRPMS/sendmail-8.14.3-8.fc12.src.rpm

No idea as to opaque (properly) processes as to Development Management internals, of course, but that CRM bug or your TAC (if any) is probably a better venue
Comment 17 Ondrej Vasik 2010-02-10 03:47:22 EST
(In reply to comment #8)
> Briefly: why?
> 
> If the reason Development Management declined this request because they viewed
> other enhancement requests as having higher priority, that's fine.

It is more about stability. It was after discussion with Quality Assurance guys and we agreed that rebasing sendmail is too risky (it's very hard to ensure that all possible user's configurations are still available without change of functionality and regressions). Therefore this enhancement request was declined. Closing that enhancement request WONTFIX.

> But if Development Management declined the request because they know (or
> suspect) upgrading to sendmail 8.14 will break things, then I want to know
> that, because we are highly inclined to spin our own 8.14 RPMs for RHEL5, and
> would appreciate foreknowledge of any potential landmines...    

No, there is no known issue with sendmail 8.14 we are aware of. But any rebase of the package in stable enterprise distribution means potential risk. Sendmail is quite a big package and it is hard to guarantee that everything will be fine after rebase (think about various configurations). It should be completely ok to spin your own sendmail-8.14 rpm's for RHEL-5 - with no guarantee, though.

Thanks for suggestion for enhancement, anyway.

Note You need to log in before you can comment on or make changes to this bug.