Bug 460568 - kde session auto-restart of firefox skips plugins
kde session auto-restart of firefox skips plugins
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firefox (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Martin Stransky
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-28 13:21 EDT by Habig, Alec
Modified: 2009-01-13 10:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-13 10:20:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 453689 None None None Never

  None (edit)
Description Habig, Alec 2008-08-28 13:21:33 EDT
With: firefox-3.0.1-1.el5.i386 and kdebase-3.5.4-18.el5.i386

Firefox, when started manually, loads in all the /usr/lib/mozilla/plugins plugins quite happily.  However, when auto-started by kde (ie, there was a firefox instance open when kde shutdown, so it brings it back automatically), no plugins are loaded.  Any open tabs etc. do come back nicely (how is that done, anyway?), the plugin list is simply completely empty.

I'm not sure if this is a firefox or a kde bug, and if it's kde, not sure which subpackage handles the restarts.  But, it's very reproducible, as well as moderately annoying, so please reassign this bug as appropriate.
Comment 1 Habig, Alec 2008-08-29 10:45:41 EDT
Two more bits of information:

1) plugins in $HOME/.mozilla/plugins do get correctly loaded, it's the ones in /usr/lib/mozilla/plugins which do not

2) The same behavior happens on F9 as well as EL5: 

  firefox-3.0.1-1.fc9.i386
  kdebase-4.1.0-1.fc9.1.i386  (from updates-testing)
Comment 2 Matěj Cepl 2008-08-29 19:37:51 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

First of all, could we get output of the command

	rpm -qa *xulrun* *firefox* *mozilla* *flash* *plugin*

Second, could I get output of the command (if you have one):

        mozilla-plugin-config -l

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Habig, Alec 2008-08-31 11:51:54 EDT
Sure.  Here's the results on my F9 system:

$ rpm -qa \*xulrun\* \*firefox\* \*mozilla\* \*flash\* \*plugin\*
alsa-plugins-pulseaudio-1.0.16-4.fc9.i386
mozilla-filesystem-1.9-2.fc9.i386
gstreamer-plugins-pulse-0.9.5-0.5.svn20070924.fc9.i386
flash-plugin-9.0.124.0-release.i386
libflashsupport-000-0.5.svn20070904.i386
gstreamer-plugins-good-0.10.8-8.fc9.i386
gstreamer-plugins-base-0.10.19-2.fc9.i386
firefox-3.0.1-1.fc9.i386
gstreamer-plugins-flumpegdemux-0.10.15-2.fc9.i386
xulrunner-1.9.0.1-1.fc9.i386
totem-mozplugin-2.23.2-5.fc9.i386
gutenprint-plugin-5.0.2-2.fc9.i386

There's no mozilla-plugin config on this box.

and on my EL5 system:

$ rpm -qa \*xulrun\* \*firefox\* \*mozilla\* \*flash\* \*plugin\*
gstreamer-plugins-good-0.10.4-4.el5.i386
yum-plugin-kmdl-0.8-10.el5.noarch
gstreamer-plugins-extras-0.10.9-2.sl.i386
totem-mozplugin-2.16.7-4.el5.i386
flash-plugin-9.0.124.0-release.i386
compiz-fusion-plugins-unsupported-0.7.2-1.i386
compiz-fusion-plugins-main-0.7.2-1.el5.i386
compiz-fusion-plugins-extra-0.7.2-1.el5.i386
xulrunner-1.9.0.1-1.el5.i386
firefox-3.0.1-1.el5.i386
gstreamer-plugins-base-0.10.9-6.el5.i386
gimp-print-plugin-4.2.7-22.i386
nspluginwrapper-0.9.91.5-22.el5.i386

$mozilla-plugin-config -l
EXCLUDE_WRAP:                                                               
libtotem*                                                                   
libjavaplugin*                                                              
EXCLUDE_LINK:                                                               

/usr/lib/mozilla/plugins-wrapped/nswrapper_32_32.nppdf.so
  Original plugin: /usr/lib/mozilla/plugins/nppdf.so     
  Wrapper version string: 0.9.91.5                       
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-gmp-plugin.so
/usr/lib/mozilla/plugins-wrapped/nswrapper_32_32.mplayerplug-in.so
  Original plugin: /usr/lib/mozilla/plugins/mplayerplug-in.so     
  Wrapper version string: 0.9.91.5                                
File/Link /usr/lib/mozilla/plugins-wrapped/nphelix.xpt            
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-mully-plugin.so
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-mully-plugin.xpt
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-complex-plugin.so
/usr/lib/mozilla/plugins-wrapped/nswrapper_32_32.mplayerplug-in-qt.so
  Original plugin: /usr/lib/mozilla/plugins/mplayerplug-in-qt.so     
  Wrapper version string: 0.9.91.5                                   
File/Link /usr/lib/mozilla/plugins-wrapped/mplayerplug-in-rm.xpt     
/usr/lib/mozilla/plugins-wrapped/nswrapper_32_32.libflashplayer.so   
  Original plugin: /usr/lib/mozilla/plugins/libflashplayer.so        
  Wrapper version string: 0.9.91.5
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-narrowspace-plugin.xpt
File/Link /usr/lib/mozilla/plugins-wrapped/mplayerplug-in-wmp.xpt
/usr/lib/mozilla/plugins-wrapped/nswrapper_32_32.mplayerplug-in-rm.so
  Original plugin: /usr/lib/mozilla/plugins/mplayerplug-in-rm.so
  Wrapper version string: 0.9.91.5
/usr/lib/mozilla/plugins-wrapped/nswrapper_32_32.mplayerplug-in-dvx.so
  Original plugin: /usr/lib/mozilla/plugins/mplayerplug-in-dvx.so
  Wrapper version string: 0.9.91.5
File/Link /usr/lib/mozilla/plugins-wrapped/mplayerplug-in.xpt
File/Link /usr/lib/mozilla/plugins-wrapped/mplayerplug-in-dvx.xpt
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-narrowspace-plugin.so
File/Link /usr/lib/mozilla/plugins-wrapped/libjavaplugin_oji.so
File/Link /usr/lib/mozilla/plugins-wrapped/mplayerplug-in-qt.xpt
/usr/lib/mozilla/plugins-wrapped/nswrapper_32_32.nphelix.so
  Original plugin: /usr/lib/mozilla/plugins/nphelix.so
  Wrapper version string: 0.9.91.5
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-complex-plugin.xpt
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-basic-plugin.xpt
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-gmp-plugin.xpt
/usr/lib/mozilla/plugins-wrapped/nswrapper_32_32.mplayerplug-in-wmp.so
  Original plugin: /usr/lib/mozilla/plugins/mplayerplug-in-wmp.so
  Wrapper version string: 0.9.91.5
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-basic-plugin.so
Comment 4 Habig, Alec 2008-08-31 12:01:32 EDT
A question though: what is the mechanism (or parameters) firefox gets called with by kde to restore sessions?
Comment 6 Florian Sievert 2008-12-14 15:38:00 EST
The desribed problem also seems to affect F10. Firefox started from kde-session does not load any plugins. If it is started manually everything seems to be fine.

gstreamer-plugins-bad-extras-0.10.9-1.fc10.i386                       
java-1.6.0-openjdk-plugin-1.6.0.0-7.b12.fc10.i386
gstreamer-plugins-farsight-0.12.9-3.fc10.i386
PackageKit-gstreamer-plugin-0.3.12-1.fc10.i386
plymouth-plugin-label-0.6.0-0.2008.11.17.3.fc10.i386
totem-mozplugin-2.24.3-1.fc10.i386
anaconda-yum-plugins-1.0-3.fc10.noarch
firefox-3.0.4-1.fc10.i386
nspluginwrapper-1.1.10-1.fc10.i386
mozilla-filesystem-1.9-2.fc10.i386
gstreamer-plugins-bad-0.10.9-1.fc10.i386
gstreamer-plugins-base-0.10.21-2.fc10.i386
gstreamer-plugins-flumpegdemux-0.10.15-4.fc10.i386
plymouth-plugin-solar-0.6.0-0.2008.11.17.3.fc10.i386
alsa-plugins-pulseaudio-1.0.18-1.rc3.fc10.i386
gstreamer-plugins-good-0.10.11-1.fc10.i386
setroubleshoot-plugins-2.0.12-1.fc10.noarch
xulrunner-1.9.0.4-1.fc10.i386
gstreamer-plugins-base-devel-0.10.21-2.fc10.i386
flash-plugin-10.0.12.36-release.i386
PackageKit-yum-plugin-0.3.12-1.fc10.i386

Note You need to log in before you can comment on or make changes to this bug.