Bug 460675 - mock --shell fails to mount /dev/pts, remote X fails
mock --shell fails to mount /dev/pts, remote X fails
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: mock (Show other bugs)
el5
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
ActualBug
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-29 13:05 EDT by Kai Engert (:kaie)
Modified: 2013-01-09 20:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-11 15:56:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kai Engert (:kaie) 2008-08-29 13:05:25 EDT
Description of problem:
ssh -Y remote-ppc-rhel 5.2-host
xauth list
mock --init
mock --install xterm
mock --shell 
export HOME=/root
xauth add ...

mock-chroot> xterm
xterm: Error 32, errno 2: No such file or directory
Reason: get_pty: not enough ptys


Version-Release number of selected component (if applicable):
mock-0.9.10-1.el5

  
Actual results:
xterm does not start


Expected results:
xterm should start


Additional info:
Thanks a lot to mikeb who found the cause.
/dev/pts is not mounted

Workaround:
mock-chroot> mount -t devpts mock_devpts /dev/pts
Comment 1 Clark Williams 2009-07-08 21:17:21 EDT
This should be addressed in 0.9.17 (actually should have worked prior to that)
Comment 2 Clark Williams 2010-09-01 10:22:59 EDT
Kai, 

Have we fixed this bug?
Comment 3 Kai Engert (:kaie) 2010-09-01 13:29:31 EDT
Sorry, I don't have an environment to verify the fix.

Let's assumed it's fixed, since the bug was understood and addressed.

Note You need to log in before you can comment on or make changes to this bug.