Bug 46069 - After kernel update NFS install not possible
After kernel update NFS install not possible
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-06-26 14:15 EDT by Bill Stephens
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-07-27 16:25:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
patch for isys/Makefile (652 bytes, patch)
2001-07-20 14:34 EDT, Matt Wilson
no flags Details | Diff

  None (edit)
Description Bill Stephens 2001-06-26 14:15:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
After upgrading the kernel to the errata 2.2.19 on my NFS RedHat image 
server, my anaconda boot/install disk no longer works.  After tracing, it 
appears that the updated kernel is using NFS v3, and the diskette wants to 
use nfs v2.  I've tried re-compiling the kernel for the diskette to add v3 
support, but everytime I boot, I get "unable to mount root drive".  Is 
there a configuration file available for the diskette kernel (preferrably 

How reproducible:

Steps to Reproduce:
1.Upgrade kernel on install source machine to errata version 2.2.19
2.Try to do a kickstart from an nfs mounted mount point from step 1 server.
3.Partition can not be mounted.  


Actual Results:  Unable to mount nfs partition

Expected Results:  partition should mount, and install should continue 
from the mounted partition.

Additional info:

Other systems running nfs v3 (kernel 2.2.19) can mount the partition 
without any problems.
Comment 1 Jeremy Katz 2001-06-28 16:26:24 EDT
Please try the updated bootnet.img which works with NFSv3 available at

*** This bug has been marked as a duplicate of 17609 ***
Comment 2 Bill Stephens 2001-06-29 08:49:10 EDT
Thanks!!!!! That worked like a champ.  Any chance of getting a source RPM for
the new anaconda?  I've had to make changes to the pump client to get it to work
with some of our routers, and noticed the new diskette has a new loader (which
might require me to update the pump client again).


Comment 3 Michael Fulbright 2001-07-02 11:08:08 EDT
Check out Red Hat Linux 7.1
Comment 4 Bill Stephens 2001-07-05 07:36:46 EDT
Can I use the 7.1 bootdisk to install 7.0?  We're not ready to move to 7.1 
yet.  We want to let the 2.4 kernel mature more, and we're waiting on a stable 
Journaling File System before our next upgrade.  7.0 has been pretty stable for 


Comment 5 Matt Wilson 2001-07-20 14:34:04 EDT
please file a bug against pump.  I'm attaching the patch for isys/Makefile.
Comment 6 Matt Wilson 2001-07-20 14:34:56 EDT
Created attachment 24327 [details]
patch for isys/Makefile

Note You need to log in before you can comment on or make changes to this bug.