Bug 460734 - libdbdsqlite3.so: undefined symbol: _dbi_internal_error_handler
libdbdsqlite3.so: undefined symbol: _dbi_internal_error_handler
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libdbi-drivers (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Tom Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-30 12:10 EDT by Marcus Alves Grando
Modified: 2013-07-02 23:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 18:12:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcus Alves Grando 2008-08-30 12:10:27 EDT
Trying to use sqlite3 driver of libdbi I've got this message:

libdbdsqlite3.so: undefined symbol: _dbi_internal_error_handler

$ rpm -qa | grep dbi
libdbi-dbd-mysql-0.8.3-1.fc9.i386
libdbi-0.8.3-1.fc9.i386
libdbi-devel-0.8.3-1.fc9.i386
libdbi-dbd-pgsql-0.8.3-1.fc9.i386
libdbi-dbd-sqlite-0.8.3-1.fc9.i386
libdbi-drivers-0.8.3-1.fc9.i386

This email warn about the problem.

http://www.mail-archive.com/libdbi-users@lists.sourceforge.net/msg00135.html

Regards
Comment 1 Tom Lane 2008-09-01 20:32:29 EDT
Fix is in CVS but I'm having some build-system problems :-(
Comment 2 Fedora Update System 2008-10-14 10:28:11 EDT
libdbi-drivers-0.8.3-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/libdbi-drivers-0.8.3-2.fc9
Comment 3 Tom Lane 2008-10-14 10:31:18 EDT
Sorry about the delay on this --- I was waiting for some docbook breakage to get fixed, because it prevented the package's documentation from building :-(
Comment 4 Marcus Alves Grando 2008-10-14 11:22:58 EDT
Ok. Thanks anyway.
Comment 5 Fedora Update System 2008-10-20 18:12:37 EDT
libdbi-drivers-0.8.3-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.