Bug 460735 - apropos outputs (rpm) entries from the whatis database, obfuscates commands
apropos outputs (rpm) entries from the whatis database, obfuscates commands
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: man (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-30 12:17 EDT by Charlweed Hymerfan
Modified: 2008-09-16 08:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-16 08:09:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charlweed Hymerfan 2008-08-30 12:17:18 EDT
Description of problem:
man -k outputs (rpm) entries from the whatis database. This appears to be a consequence of request  175595, however, it breaks apropos.
Finding (rpm) entries with apropos is not useful, it makes it hard to find commands, and it makes the man page for appopos wrong. Outputting the (rpm) entries means that the whatis database is no longer a
"set of database files containing short descriptions of system
commands" because the things it puts in there are *not* system
commands.
 
It makes it particularly difficult to find commands for unfamiliar software, because the output is misleading. For example typing "man -k kdm" displays

fedorawaves-kdm-theme (rpm) - Fedora Waves KDM theme
kde-settings-kdm    (rpm) - Config files for kdebase-workspace(kdm)


Which gives no information for the "kdm" command, but makes it appear as if kde-settings-kdm is a command. Additionally frustrating is that there is no man page for kde-settings-kdm. Even if the man pages for kdm has been correctly installed, this (bug/feature) makes it more difficult to find them.


Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. man -k kdm
2.
3.
  
Actual results:
fedorawaves-kdm-theme (rpm) - Fedora Waves KDM theme
kde-settings-kdm    (rpm) - Config files for kdebase-workspace(kdm)

Expected results:
Info on KDM man page

Additional info:
Comment 1 Federico Lucifredi 2008-09-07 15:04:40 EDT
I have looked at this on Ivana's request. I would have to agree with the submitter that it is a bug - makewhatis should be indexing man pages only, not packages. One option would be to index only man pages in packages (not package names), and flagging them with "(not installed)" in front of the usual "name - description" pair, but I understand that that is not what the current patch does.
Comment 2 Ivana Varekova 2008-09-16 08:09:52 EDT
Thanks for the bug report and thanks to Frederico for his opinion. I have removed the including of rmp data to whatis database in man-1.6f-11.fc10.

Note You need to log in before you can comment on or make changes to this bug.