Bug 460750 - fr_CH XLayout doesn't work
fr_CH XLayout doesn't work
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-30 17:50 EDT by Patrick Guenther
Modified: 2009-07-14 10:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 10:04:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (618 bytes, text/plain)
2008-10-25 04:39 EDT, Patrick Guenther
no flags Details
setxkbmap -print > xkbmap.txt (246 bytes, text/plain)
2008-10-25 04:42 EDT, Patrick Guenther
no flags Details
xkbcomp :0 - > xkbcomp.txt (36.75 KB, text/plain)
2008-10-25 04:45 EDT, Patrick Guenther
no flags Details

  None (edit)
Description Patrick Guenther 2008-08-30 17:50:31 EDT
Description of problem:

Alt Gr keys as well as as other keys don't work  on X when xorg.conf uses a XLayout fr_CH, which forbids access to symbols like @ or #.

This doesn't occur in console mode (init 3)

I tried following thing:

Creation of a keyboard map with xkeycaps (102 Key;XFree;Swiss French), loaded with xmodmap.

Version-Release number of selected component (if applicable):
xkeycaps-2.46-7.fc9.3

How reproducible:

Install Fedora 9 on VMWare 6 using a Swiss-French Keyboard. Language doesn't matter.


Additional info:

Hardware: Dell Precision M6300
Software: vmware 6
Lokks like https://bugzilla.redhat.com/show_bug.cgi?id=163718
Comment 1 Peter Hutterer 2008-10-22 23:43:37 EDT
Please attach your xorg.conf and your Xorg.log, and the output of "setxkbmap -print" and "xkbcomp :0 -".
Comment 2 Patrick Guenther 2008-10-25 04:39:07 EDT
Created attachment 321494 [details]
xorg.conf
Comment 3 Patrick Guenther 2008-10-25 04:42:24 EDT
Created attachment 321495 [details]
setxkbmap -print > xkbmap.txt
Comment 4 Patrick Guenther 2008-10-25 04:45:28 EDT
Created attachment 321496 [details]
xkbcomp :0 - > xkbcomp.txt 

Please note that I am getting following warning:

<QUOTE>

Warning:          Could not load keyboard geometry for :0
                  BadAlloc (insufficient resources for operation)
                  Resulting keymap file will not describe geometry

</QUOTE>
Comment 5 Patrick Guenther 2008-10-25 04:48:42 EDT
About Xorg.log, the system hasn't created one

PS: The keyboard issue is also occuring on an other computer nativly Fedora Core 9
Comment 6 Peter Hutterer 2008-10-27 00:12:59 EDT
wait a minute, did you create the keymap yourself? or what exactly did you do to get that keymap? None of your keys have more than 2 shift levels, so even if ralt would map correctly (it doesn't) there wouldn't be anything to map to.

what's wrong with the swiss keyboard layout you can select from the gnome config tools? (or by running "setxkbmap -layout "ch(fr)" if gnome isn't an option.)
Comment 7 Patrick Guenther 2008-10-28 13:41:20 EDT
The keyboard layout is fr_CH in System -> Preferences -> Hardware -> Keyboard and it's the only defined keyboard.

I just made another test as it seems that the keyboard layout may be in question:

As the swiss german keyboard has small difference and at least for @ (ATL-R 2) it's on the same place, I have tried to add it and had following message wen switching to it:

Error activating XKB configuration.

X server version data:
The X.Org foundaion
10500000

If you report this situation as a bug, please include:
the result of xprop -root | grep XKB
the result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kdb


# xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "fr_CH", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "fr_CH", "", ""

and  

# gconftool-2 -R /desktop/gnome/peripherals/keyboard/kdb

returns nothing

I hope this helps and thanks for your help
Comment 8 Peter Hutterer 2008-10-28 21:11:46 EDT
i'm still confused here. you mentioned xkeycaps in the first comment, are you still using it?

please remove your .xmodmap file (the one generated by xkeycaps) and restart the X server. Then select Switzerland, Variant French in the gnome tool. Does this provide the correct keyboard mapping?
If not, please provide the versions of xkeyboard-config, xorg-x11-server and xorg-x11-drv-evdev.
Comment 9 Patrick Guenther 2008-10-29 16:49:21 EDT
I was confuded to:
- I removed the .xmodmap files, restarted X server: no change
- Finally I removed the fr_CH keybord and used the Switzerland French one 
  using the Gnome configuration: Everything OK
  
  
I did already 3 installations and always run into this problem with the
Gnome Swiss french keyboard.

Conclusion: This is not keyboard issue, but an installer problem.

To get the fine word, I made a new installation. Find the install log bellow


Fedora Core 9 x86_64 DVD

01. Install or upgrade an existing system
02. Language -> English (English)
03. Keyboard -> Swiss French
  ... defaults ...
04. Packages
    Office and Productivity (Not selected)
    Software Development (Not selected)
    Web Server (Not selected)

  Customize later

05. Reboot
    ----------
    First boot
    ----------
06. Create User
    - THE KEYBOARD IS FRENCH ( A in state of Q, shift to have numbers)
07. Login Screen
    - THE KEYBOARD SWITCHED TO SWISS FRENCH
08. In System -> Hardware -> Keyboard
    Layouts -> fr_CH   
    - THE KEYBOARD HAS NO 2ND LEVEL SHIFT
09. Add the Switzerland French keyboard
10. Removed fr_CH keyboard

Everything ok.

Looks like an installer problem.
  
Thanks for the help. It solved my problem. Shall I open a new bug ?
Comment 10 Bug Zapper 2009-06-09 22:35:16 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Bug Zapper 2009-07-14 10:04:11 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.