Bug 460755 - No menu entries for BrOffice.org
No menu entries for BrOffice.org
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-31 01:23 EDT by Igor Pires Soares
Modified: 2008-09-07 17:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-07 17:16:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
seems to work for me (79.41 KB, image/png)
2008-08-31 05:37 EDT, Caolan McNamara
no flags Details

  None (edit)
Description Igor Pires Soares 2008-08-31 01:23:58 EDT
Description of problem:
There are no menu entries for BrOffice.org in Rawhide. The .desktop files are in /usr/share/applications directory, but they don't actually launch the applications.

Version-Release number of selected component (if applicable):
broffice.org-calc-3.0.0-3.1.fc10.i386.rpm
broffice.org-draw-3.0.0-3.1.fc10.i386.rpm
broffice.org-impress-3.0.0-3.1.fc10.i386.rpm
broffice.org-writer-3.0.0-3.1.fc10.i386.rpm

Steps to Reproduce:
1. Install broffice.org-*
2. Go to Office category in GNOME Application menu.
  
Actual results:
Nothing related to BrOffice.org appears in Office category.

Expected results:
BrOffice.org apps should be listed in menu.
Comment 1 Caolan McNamara 2008-08-31 05:37:45 EDT
Created attachment 315442 [details]
seems to work for me
Comment 2 Caolan McNamara 2008-08-31 05:55:11 EDT
Does manually running 

update-desktop-database /usr/share/applications 

make any difference ?
Comment 3 Igor Pires Soares 2008-08-31 17:17:30 EDT
No, it don't. But I think I figure out where the problem is.

I have removed the "TryExec" directive at the end of the .desktop files and it worked well. In broffice.org-*.desktop files the "TryExec" points to OpenOffice.org executable filenames. Maybe that's why the whole thing happens. I also noticed that these .desktop files have different permissions from other ones. Most files are rw-r--r-- but these ones are read-only.
Comment 4 Caolan McNamara 2008-09-01 03:18:21 EDT
Indeed, the TryExec is on the wrong set of .desktops, though it didn't make a serious difference here. Fix checked in, will be in >= 3.0.0-4.2
Comment 5 Caolan McNamara 2008-09-07 17:16:54 EDT
No TryExec in broffice.org-* now

Note You need to log in before you can comment on or make changes to this bug.