Bug 460804 - No connections via terminal
No connections via terminal
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-01 05:44 EDT by Paul Miller
Modified: 2014-01-21 18:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-01 15:15:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Miller 2008-09-01 05:44:24 EDT
Description of problem:
After updating from fc9 to fc10, the terminal is no longer establishing online connections. When attempting a yum update for example, I get a ERROR 14, and then after attempting to switch mirrors, I get a ERROR 4. Terminal fails to pull anything from the web. Mozilla Firefox, and presumably any other browser, still gets a connection and I can happily browse the internet. Pidgin and other internet based applications still function like usual.

Version-Release number of selected component (if applicable):
Currently not in a position to check the full version. But, It just updated to fc10 today (08/31/2008) between 6 and 7pm Central (US).

How reproducible:
100%. Unsure of cause however. It doesn't appear to be happening to everyone obviously, however.

Steps to Reproduce:
1. Open terminal
2. Attempt to pull package from any mirror
3. Errors reported.
  
Actual results:
Cannot update or download packages via terminal.

Expected results:
Update software or install software via terminal.

Additional info:
Running on a wired Realtek RTL8169 network adapter on an Asus P5K Deluxe motherboard. Again, other applications have no problem connecting. Other operating systems on PC have no trouble with connections, either.
Comment 1 Kevin Fenzi 2008-09-01 12:02:35 EDT
This would seem to me to be a problem with yum, rather than the Xfce Terminal program. 

Can you add a comment showing the exact command you are running and the output?
Comment 2 Paul Miller 2008-09-01 15:10:06 EDT
Here are two examples via yum 3.2.19:

[root@paul-fedora ~]# yum update
Loaded plugins: priorities, refresh-packagekit
http://rpm.livna.org/fedora/9.90.1/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
http://livna.cat.pdx.edu/fedora/9.90.1/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/9.90.1/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/9.90.1/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
http://mirror.atrpms.net/livna/fedora/9.90.1/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/9.90.1/x86_64/repodata/repomd.xml: [Errno 4] IOError: [Errno ftp error] 550 Failed to change directory.
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: livna. Please verify its path and try again

&

[root@paul-fedora ~]# yum install wget
Loaded plugins: priorities, refresh-packagekit
http://rpm.livna.org/fedora/9.90.1/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
http://livna.cat.pdx.edu/fedora/9.90.1/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/9.90.1/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/9.90.1/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
http://mirror.atrpms.net/livna/fedora/9.90.1/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/9.90.1/x86_64/repodata/repomd.xml: [Errno 4] IOError: [Errno ftp error] 550 Failed to change directory.
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: livna. Please verify its path and try again
Comment 3 seth vidal 2008-09-01 15:15:54 EDT
You've upgraded your fedora-release pkg which bumps the version from 9 to 9.90.1 - this means that all of your repo urls which use $releasever no longer have the right path.
Comment 4 Paul Miller 2008-09-01 15:32:17 EDT
I see... Is this something that I can alter/repair via yum.conf? Just change the urls/mirrors to a 9 instead of 9.90.1? Thanks for the timely responses, by the way.
Comment 5 seth vidal 2008-09-01 15:49:36 EDT
Well, excluding the livna repos, you probably want to disable all the fedora9 repos and just use rawhide.
Comment 6 Paul Miller 2008-09-01 16:25:42 EDT
I apologize if I may be wasting your time, since the primary objective of this service is to report possible bugs, but I'm fairly new with fedora 9 and it's workings. I've searched around and found where the repos are kept but I'm not sure which file to alter and/or what to change once in it. Thanks.
Comment 7 seth vidal 2008-09-01 22:58:24 EDT
I guess I'm confused. You just started using f9 but you've already upgraded to rawhide? Any particular reason?

If you want to edit the files look in /etc/yum.repos.d/*.repo
Comment 8 Paul Miller 2008-09-01 23:16:40 EDT
Well... For whatever reason the update manager came up out of nowhere to inform me that I had 904 updates. I allowed it to continue and halfway through the updates I notice it was installing rc5.f10. I just figured it was some sort of early release being pushed out for whatever reason and allowed it to continue. Then things went badly. I think I'm just gonna reinstall f9 and make sure it doesn't try and do that again. I'm probably too much of a novice to help out a whole lot with bug reporting anyway! Thanks a lot for your help.

Note You need to log in before you can comment on or make changes to this bug.