Bug 460816 - rhnreg_ks no xen
rhnreg_ks no xen
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Pradeep Kilambi
http://rhn.redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-01 10:11 EDT by ITT Tech
Modified: 2009-10-13 21:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-20 22:12:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ITT Tech 2008-09-01 10:11:46 EDT
Description of problem:
if i register using rhnreg_ks i cannot "yum install xen"
however if i use rhn_register it works
Comment 1 Daniel Berrange 2008-09-01 10:18:04 EDT
This isn't a Xen bug - needs to be assigned to RHN.
Comment 2 Clifford Perry 2009-02-20 22:12:17 EST
This is not a bug. rhnreg_ks  with username/password with register you to just the base channel, and not the virtualization child channel. If you use an activation key with rhnreg_ks, it will subscribe you to the channels associated with the activation key. The usage of rhn_register though is a different beast - it is designed to understand and subscribe to additional channels on registration. We recommend to use rhnreg_ks with activation keys for en-mass registrations within automated fashion where you wish to register a lot of systems to the same set of channels. 

Cliff.

Note You need to log in before you can comment on or make changes to this bug.