Bug 460818 - wlassistant won't work
wlassistant won't work
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: wlassistant (Show other bugs)
9
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-01 10:33 EDT by Alexey Kuznetsov
Modified: 2009-07-14 10:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 10:43:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexey Kuznetsov 2008-09-01 10:33:13 EDT
When i tried to run wlassisnant and connect to my ap i got an error.

When i tried same configs and commands from bash evertying work fine. Fedora 8 release work fine on my machine.

here is the wlassisant output:

[axet@mini network-scripts]$ sudo wlassistant 
kbuildsycoca running...
Loaded application options.
All interfaces: br0, eth0, pan0, ppp0, virbr0, wlan0, wmaster0
Wireless interface(s): wlan0
Permissions checked.
DHCP Client: dhclient
All executables found.
scan: /sbin/iwlist wlan0 scan
Networks found: 1
ACTION: CONNECT.
Running DHCP client found.
kill_dhcp: /sbin/dhclient -r wlan0
No pre-connection command specified.
iwconfig_set: /sbin/iwconfig wlan0 mode managed channel 1 key off essid wifi.tax.local
iwconfig_ap: /sbin/iwconfig wlan0 ap 00:1C:F0:BD:01:06
==>stderr: Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory
Using wpa_supplicant driver: wext
WPA client started. Waiting for status...
==>stderr: Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory
CONNECTION FAILED.
disconnect: /sbin/iwconfig wlan0 mode managed key off ap off essid off




here is the console run:

1)
[root@mini network-scripts]# /usr/sbin/wpa_supplicant -W -Dwext -iwlan0 -c/home/axet/.kde/share/config/wlassistantwpa
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - CTRL-EVENT-SCAN-RESULTS 
CTRL-EVENT-SCAN-RESULTS 
Trying to associate with 00:1c:f0:bd:01:06 (SSID='wifi.tax.local' freq=2412 MHz)
Associated with 00:1c:f0:bd:01:06
WPA: Key negotiation completed with 00:1c:f0:bd:01:06 [PTK=CCMP GTK=CCMP]
CTRL-EVENT-CONNECTED - Connection to 00:1c:f0:bd:01:06 completed (auth) [id=0 id_str=]

2)
[axet@mini network-scripts]$ sudo wpa_cli 
wpa_cli v0.6.3
Copyright (c) 2004-2008, Jouni Malinen <j@w1.fi> and contributors

This program is free software. You can distribute it and/or modify it
under the terms of the GNU General Public License version 2.

Alternatively, this software may be distributed under the terms of the
BSD license. See README and COPYING for more details.


Selected interface 'wlan0'

Interactive mode

<2>CTRL-EVENT-SCAN-RESULTS 
> <2>CTRL-EVENT-SCAN-RESULTS 
<2>Trying to associate with 00:1c:f0:bd:01:06 (SSID='wifi.tax.local' freq=2412 MHz)
<2>Associated with 00:1c:f0:bd:01:06
<2>WPA: Key negotiation completed with 00:1c:f0:bd:01:06 [PTK=CCMP GTK=CCMP]
<2>CTRL-EVENT-CONNECTED - Connection to 00:1c:f0:bd:01:06 completed (auth) [id=0 id_str=]



3)
[root@mini network-scripts]# dhclient wlan0

and i got an ip address.
Comment 1 Bug Zapper 2009-06-09 22:35:51 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Bug Zapper 2009-07-14 10:43:42 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.