Bug 460962 - when connecting a USB wacom tablet (intuos3 6X8) udev does not create the /dev/input/wacomX symlink
when connecting a USB wacom tablet (intuos3 6X8) udev does not create the /de...
Status: CLOSED DUPLICATE of bug 436889
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: linuxwacom (Show other bugs)
5.2
x86_64 Linux
medium Severity high
: rc
: ---
Assigned To: Aristeu Rozanski
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-02 19:00 EDT by grants
Modified: 2008-09-04 10:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-04 10:18:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CentOS 3031 None None None Never

  None (edit)
Description grants 2008-09-02 19:00:43 EDT
Description of problem:
udevinfo shows correct information but when tablet is connected it does not propergate a KERNEL=="event*" type event to udev.


Version-Release number of selected component (if applicable):
5.2 x86_64 
kernel-2.6.18-92.1.6.el5
linuxwacom-0.7.4.3-2.el5

How reproducible:
always

Steps to Reproduce:
1. Install 64bit version 5.2
2. Plug in wacom Intuos 3 tablet
3. /dev/input/wacom does not get created
  
Actual results:
input and event devices get created under /dev/input only

Expected results:
wacom device/link should be created in /dev/input

Additional info:
-----------------------
 udevinfo -a -p /sys/class/input/event3

Udevinfo starts with the device specified by the devpath and then
walks up the chain of parent devices. It prints for every device
found, all possible attributes in the udev rules key format.
A rule to match, can be composed by the attributes of the device
and the attributes from one single parent device.

  looking at device '/class/input/input3/event3':
    KERNEL=="event3"
    SUBSYSTEM=="input"
    SYSFS{dev}=="13:67"

  looking at parent device '/class/input/input3':
    ID=="input3"
    BUS=="input"
    DRIVER==""
    SYSFS{uniq}==""
    SYSFS{phys}==""
    SYSFS{name}=="Wacom Intuos3 6x8"

  looking at parent device '/devices/pci0000:00/0000:00:1d.3/usb4/4-1/4-1:1.0':
    ID=="4-1:1.0"
    BUS=="usb"
    DRIVER=="wacom"
    SYSFS{modalias}=="usb:v056Ap00B1d0102dc00dsc00dp00ic03isc01ip02"
    SYSFS{bInterfaceProtocol}=="02"
    SYSFS{bInterfaceSubClass}=="01"
    SYSFS{bInterfaceClass}=="03"
    SYSFS{bNumEndpoints}=="01"
    SYSFS{bAlternateSetting}==" 0"
    SYSFS{bInterfaceNumber}=="00"

  looking at parent device '/devices/pci0000:00/0000:00:1d.3/usb4/4-1':
    ID=="4-1"
    BUS=="usb"
    DRIVER=="usb"
    SYSFS{configuration}==""
    SYSFS{product}=="PTZ-630"
    SYSFS{manufacturer}=="Tablet"
    SYSFS{maxchild}=="0"
    SYSFS{version}==" 1.10"
    SYSFS{devnum}=="2"
    SYSFS{speed}=="12"
    SYSFS{bMaxPacketSize0}=="8"
    SYSFS{bNumConfigurations}=="1"
    SYSFS{bDeviceProtocol}=="00"
    SYSFS{bDeviceSubClass}=="00"
    SYSFS{bDeviceClass}=="00"
    SYSFS{bcdDevice}=="0102"
    SYSFS{idProduct}=="00b1"
    SYSFS{idVendor}=="056a"
    SYSFS{bMaxPower}=="300mA"
    SYSFS{bmAttributes}=="80"
    SYSFS{bConfigurationValue}=="1"
    SYSFS{bNumInterfaces}==" 1"

  looking at parent device '/devices/pci0000:00/0000:00:1d.3/usb4':
    ID=="usb4"
    BUS=="usb"
    DRIVER=="usb"
    SYSFS{configuration}==""
    SYSFS{serial}=="0000:00:1d.3"
    SYSFS{product}=="UHCI Host Controller"
    SYSFS{manufacturer}=="Linux 2.6.18-92.1.6.el5 uhci_hcd"
    SYSFS{maxchild}=="2"
    SYSFS{version}==" 1.10"
    SYSFS{devnum}=="1"
    SYSFS{speed}=="12"
    SYSFS{bMaxPacketSize0}=="64"
    SYSFS{bNumConfigurations}=="1"
    SYSFS{bDeviceProtocol}=="00"
    SYSFS{bDeviceSubClass}=="00"
    SYSFS{bDeviceClass}=="09"
    SYSFS{bcdDevice}=="0206"
    SYSFS{idProduct}=="0000"
    SYSFS{idVendor}=="0000"
    SYSFS{bMaxPower}==" 0mA"
    SYSFS{bmAttributes}=="e0"
    SYSFS{bConfigurationValue}=="1"
    SYSFS{bNumInterfaces}==" 1"

  looking at parent device '/devices/pci0000:00/0000:00:1d.3':
    ID=="0000:00:1d.3"
    BUS=="pci"
    DRIVER=="uhci_hcd"
    SYSFS{broken_parity_status}=="0"
    SYSFS{enable}=="1"
    SYSFS{modalias}=="pci:v00008086d0000268Bsv0000103Csd00001307bc0Csc03i00"
    SYSFS{local_cpus}=="00000000,00000000,00000000,00000000,00000000,00000000,00000000,000000ff"
    SYSFS{irq}=="98"
    SYSFS{class}=="0x0c0300"
    SYSFS{subsystem_device}=="0x1307"
    SYSFS{subsystem_vendor}=="0x103c"
    SYSFS{device}=="0x268b"
    SYSFS{vendor}=="0x8086"

  looking at parent device '/devices/pci0000:00':
    ID=="pci0000:00"
    BUS==""
    DRIVER==""

------------------
Notice no kernel ouput when wacom connected
[root@gorgeous ~]# udevmonitor --env
udevmonitor prints the received event from the kernel [UEVENT]
and the event which udev sends out after rule processing [UDEV]

UEVENT[1218000628.945328] add@/devices/pci0000:00/0000:00:1d.3/usb4/4-1
ACTION=add
DEVPATH=/devices/pci0000:00/0000:00:1d.3/usb4/4-1
SUBSYSTEM=usb
SEQNUM=1006
PHYSDEVBUS=usb
PHYSDEVDRIVER=usb

UEVENT[1218000628.945914] add@/devices/pci0000:00/0000:00:1d.3/usb4/4-1/usbdev4.3_ep00
ACTION=add
DEVPATH=/devices/pci0000:00/0000:00:1d.3/usb4/4-1/usbdev4.3_ep00
SUBSYSTEM=usb_endpoint
SEQNUM=1007
MAJOR=442
MINOR=6146

UDEV [1218000628.946251] add@/devices/pci0000:00/0000:00:1d.3/usb4/4-1
UDEV_LOG=3
ACTION=add
DEVPATH=/devices/pci0000:00/0000:00:1d.3/usb4/4-1
SUBSYSTEM=usb
SEQNUM=1006
PHYSDEVBUS=usb
PHYSDEVDRIVER=usb
UDEVD_EVENT=1

UEVENT[1218000628.948312] add@/devices/pci0000:00/0000:00:1d.3/usb4/4-1/4-1:1.0
ACTION=add
DEVPATH=/devices/pci0000:00/0000:00:1d.3/usb4/4-1/4-1:1.0
SUBSYSTEM=usb
SEQNUM=1008
PHYSDEVBUS=usb
DEVICE=/proc/bus/usb/004/003
PRODUCT=56a/b1/102
TYPE=0/0/0
INTERFACE=3/1/2
MODALIAS=usb:v056Ap00B1d0102dc00dsc00dp00ic03isc01ip02

UEVENT[1218000628.948884] add@/class/input/input4
ACTION=add
DEVPATH=/class/input/input4
SUBSYSTEM=input
SEQNUM=1009
PHYSDEVPATH=/devices/pci0000:00/0000:00:1d.3/usb4/4-1/4-1:1.0
PHYSDEVBUS=usb
PHYSDEVDRIVER=wacom
PRODUCT=3/56a/b1/102
NAME="Wacom Intuos3 6x8"
EV=1f
KEY=1cff 1f00ff 0 0 0 0
REL=100
ABS=1000f00017b
MSC=1
MODALIAS=input:b0003v056Ap00B1e0102-e0,1,2,3,4,k100,101,102,103,104,105,106,107,110,111,112,113,114,140,141,142,143,144,145,146,147,14A,14B,14C,r8,a0,1,3,4,5,6,8,18,19,1A,1B,28,m0,lsfw

UEVENT[1218000628.948938] add@/class/input/input4/mouse1
ACTION=add
DEVPATH=/class/input/input4/mouse1
SUBSYSTEM=input
SEQNUM=1010
PHYSDEVPATH=/devices/pci0000:00/0000:00:1d.3/usb4/4-1/4-1:1.0
PHYSDEVBUS=usb
PHYSDEVDRIVER=wacom
MAJOR=13
MINOR=33

UEVENT[1218000628.948990] add@/class/input/input4/event3
ACTION=add
DEVPATH=/class/input/input4/event3
SUBSYSTEM=input
SEQNUM=1011
PHYSDEVPATH=/devices/pci0000:00/0000:00:1d.3/usb4/4-1/4-1:1.0
PHYSDEVBUS=usb
PHYSDEVDRIVER=wacom
MAJOR=13
MINOR=67

UEVENT[1218000628.967314] add@/devices/pci0000:00/0000:00:1d.3/usb4/4-1/4-1:1.0/usbdev4.3_ep81
ACTION=add
DEVPATH=/devices/pci0000:00/0000:00:1d.3/usb4/4-1/4-1:1.0/usbdev4.3_ep81
SUBSYSTEM=usb_endpoint
SEQNUM=1012
MAJOR=442
MINOR=6146

UEVENT[1218000628.967624] add@/class/usb_device/usbdev4.3
ACTION=add
DEVPATH=/class/usb_device/usbdev4.3
SUBSYSTEM=usb_device
SEQNUM=1013
PHYSDEVPATH=/devices/pci0000:00/0000:00:1d.3/usb4/4-1
PHYSDEVBUS=usb
PHYSDEVDRIVER=usb
MAJOR=189
MINOR=386

UDEV [1218000629.148851] add@/devices/pci0000:00/0000:00:1d.3/usb4/4-1/usbdev4.3_ep00
UDEV_LOG=3
ACTION=add
DEVPATH=/devices/pci0000:00/0000:00:1d.3/usb4/4-1/usbdev4.3_ep00
SUBSYSTEM=usb_endpoint
SEQNUM=1007
MAJOR=442
MINOR=6146
UDEVD_EVENT=1
DEVNAME=/dev/usbdev4.3_ep00

UDEV [1218000629.250319] add@/devices/pci0000:00/0000:00:1d.3/usb4/4-1/4-1:1.0
UDEV_LOG=3
ACTION=add
DEVPATH=/devices/pci0000:00/0000:00:1d.3/usb4/4-1/4-1:1.0
SUBSYSTEM=usb
SEQNUM=1008
PHYSDEVBUS=usb
DEVICE=/proc/bus/usb/004/003
PRODUCT=56a/b1/102
TYPE=0/0/0
INTERFACE=3/1/2
MODALIAS=usb:v056Ap00B1d0102dc00dsc00dp00ic03isc01ip02
UDEVD_EVENT=1

UDEV [1218000629.454194] add@/devices/pci0000:00/0000:00:1d.3/usb4/4-1/4-1:1.0/usbdev4.3_ep81
UDEV_LOG=3
ACTION=add
DEVPATH=/devices/pci0000:00/0000:00:1d.3/usb4/4-1/4-1:1.0/usbdev4.3_ep81
SUBSYSTEM=usb_endpoint
SEQNUM=1012
MAJOR=442
MINOR=6146
UDEVD_EVENT=1
DEVNAME=/dev/usbdev4.3_ep81

UDEV [1218000629.555110] add@/class/input/input4
UDEV_LOG=3
ACTION=add
DEVPATH=/class/input/input4
SUBSYSTEM=input
SEQNUM=1009
PHYSDEVPATH=/devices/pci0000:00/0000:00:1d.3/usb4/4-1/4-1:1.0
PHYSDEVBUS=usb
PHYSDEVDRIVER=wacom
PRODUCT=3/56a/b1/102
NAME="Wacom Intuos3 6x8"
EV=1f
KEY=1cff 1f00ff 0 0 0 0
REL=100
ABS=1000f00017b
MSC=1
MODALIAS=input:b0003v056Ap00B1e0102-e0,1,2,3,4,k100,101,102,103,104,105,106,107,110,111,112,113,114,140,141,142,143,144,145,146,147,14A,14B,14C,r8,a0,1,3,4,5,6,8,18,19,1A,1B,28,m0,lsfw
UDEVD_EVENT=1

UDEV [1218000629.758990] add@/class/input/input4/mouse1
UDEV_LOG=3
ACTION=add
DEVPATH=/class/input/input4/mouse1
SUBSYSTEM=input
SEQNUM=1010
PHYSDEVPATH=/devices/pci0000:00/0000:00:1d.3/usb4/4-1/4-1:1.0
PHYSDEVBUS=usb
PHYSDEVDRIVER=wacom
MAJOR=13
MINOR=33
UDEVD_EVENT=1
DEVNAME=/dev/input/mouse1

UDEV [1218000629.760141] add@/class/input/input4/event3
UDEV_LOG=3
ACTION=add
DEVPATH=/class/input/input4/event3
SUBSYSTEM=input
SEQNUM=1011
PHYSDEVPATH=/devices/pci0000:00/0000:00:1d.3/usb4/4-1/4-1:1.0
PHYSDEVBUS=usb
PHYSDEVDRIVER=wacom
MAJOR=13
MINOR=67
UDEVD_EVENT=1
DEVNAME=/dev/input/event3

UDEV [1218000629.763174] add@/class/usb_device/usbdev4.3
UDEV_LOG=3
ACTION=add
DEVPATH=/class/usb_device/usbdev4.3
SUBSYSTEM=usb_device
SEQNUM=1013
PHYSDEVPATH=/devices/pci0000:00/0000:00:1d.3/usb4/4-1
PHYSDEVBUS=usb
PHYSDEVDRIVER=usb
MAJOR=189
MINOR=386
UDEVD_EVENT=1
DEVNAME=/dev/bus/usb/004/003
Comment 1 Aristeu Rozanski 2008-09-03 13:11:30 EDT
this is fixed on the next package version:
http://people.redhat.com/arozansk/wacom_rhel5/linuxwacom-0.7.8.3-3.el5.src.rpm
please give it a try and let me know how it goes. there're binary versions of
this package on that URL too.
Comment 2 grants 2008-09-03 20:13:30 EDT
yep that seems to work. Thanks for that.
Comment 3 Aristeu Rozanski 2008-09-04 10:18:26 EDT
Ok, I'll close this bug. If you have further problems, please feel free to reopen.

*** This bug has been marked as a duplicate of bug 436889 ***

Note You need to log in before you can comment on or make changes to this bug.